Community
Showing results for 
Search instead for 
Do you mean 
Reply

upgraded from ACT7(2005) to ACT2012 - layouts not transfering

New Member
Posts: 8
Country: USA

upgraded from ACT7(2005) to ACT2012 - layouts not transfering

I am upgrading from ACT7 2005 to ACT 2012, both Premium and for windows.  Instead of going cold turkey with the upgrade, since I never trust a database upgrade, I built a new VM loaded all the necessary drivers/features and loaded a clean copy of ACT2012.  I did a backup of the existing database and did a restore as to port the data to ACT2012.  In the old database the users had created some different layouts with custom fields and tabs.  I can get the layouts open and there is data in the fields, however in the old database there are dropdowns to select values which are missing.  When running a query against those fields the query does not return data.  This is not across the board with all the fields only with some.  The fields are product specific so they do not conflict with ACT specific fields.

 

So I'm curious, why some field values made the leap and others didn't.  Is is due to the backup/restore instead of the upgrade?  Is it the layouts that need to be recopied?

 

Any help would be appreciated

Bronze Contributor
Posts: 1,272
Country: USA

Re: upgraded from ACT7(2005) to ACT2012 - layouts not transfering

When you restore a database and open it the first time, it is going to update it to the current schema for the version yu are running.  It sounds like a bug I saw that occurred starting in one of the most recent releases.  If you look at the dropdowns, I bet you will find a blank space at the top of the dropdown.  You need to remove it.  If you have lots of dropdowns, it's one at a time.  The other thing to check for is nulls in yes/no fields.  Taht happened a lot with 2005 databases.  Do a lookup all contacts.  Then do a lookup contacts with Yes/No equaling True - get the count.  Do the same for false.  If the last two numbers don't add up to all contacts you have null records which can screw up drops.  What I would do is do the lookup of all contacts showing the yes/no field.  then omit all the ones that say yes.  Do an Edit Replace on the dropdown and set them to no (false).

Patricia Egen
Certified ACT! Consultant, Trainer, Developer
www.egenconsulting.com
(423) 875-2652

Follow us on:


Visit our Popular ACT Wizards Page Wizards Here!

New Member
Posts: 8
Country: USA

Re: upgraded from ACT7(2005) to ACT2012 - layouts not transfering

[ Edited ]

I assume this is to be done on the ACT2012 or do I need to do that on the ACT2005 version then (re) restore

New Member
Posts: 8
Country: USA

Re: upgraded from ACT7(2005) to ACT2012 - layouts not transfering

I see what is happening now.  There are some field names that are not being transferred.  It is reverting it or renaming it to User1,User2,.....

Is there a way to determine why it did this or how many fields or other items did not copy.