Community
Showing results for 
Search instead for 
Do you mean 
Reply

unable to sync database, able to start "Accept Incoming Syncs"

Astute Commentator
Posts: 17
Country: USA

unable to sync database, able to start "Accept Incoming Syncs"

[ Edited ]

Have 2 copies of ACT 2012 (SP1).  Started a sync set and generated a sync database on the host machine (desktop).  Transferred it to the (client) laptop via flashdrive and laptop ACT loaded it okay.

 

On host machine I tried to enable "Accept Incoming Syncs" but this appears to be greyed out --nothing happens.

Of course the laptop won't connect to the host.  The sync log says

 

======== SYNC SESSION - 4/7/2013 12:17:36 AM ========

[ Info | 4/7/2013 12:17:37 AM ]Message: Sync remote client created.
[ Error | 4/7/2013 12:18:20 AM ]Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

The laptop automatically had the correct name of the host & the port #'s are both 65100.  Both computers have Windows-7 Pro 32 bit.  Have hopefully turned off the User Protocol thing or the User Authorization thing via registry edit.  I've always had problemswith networks on win-7.  I could never view another computer's directories no matter how I share them.  No clue why networks never share anything.

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: unable to sych database, apparently unable to start "Accept Incoming Sychs"

If the host machine is Vista or Windows 7, try:
- close Sage ACT!
- right-click on Sage ACT! icon > select 'Run as administrator'
- attempt to enable 'Accept Incoming Syncs'
Greg Martin
Sage
Astute Commentator
Posts: 17
Country: USA

Re: unable to sync database, able to start "Accept Incoming Syncs" fine

[ Edited ]

Ran as Administrator.  Doesn't seem to change anything. Tried to enable Accept Incoming syncs & got following error msg

 

The SQL Database instance is unavailable.  Contact your administrator (of course) for (no) assistance.

 

Note that I have 3 databases apparently.  The listing is as follows, the sych set is Aurelian.

 

Name                                               Machine                 Synch Set              Main Database          Status           

 

FSI_DBv14_2013March              TIBERIUS\ACT7       FSI_home          FlowSims_2010         ACTIVE

Gothics                                           "same as above"     "                            "                                      "

Aurelian                                          "                                   "                            "                                     "

 

FSI_DBv14_2013March is the database I was/am using before trying sync sets

Gothics was created without a password as part of a sych set.  I perhaps should delete that one except that I really don't want a password..

Aurelian is the dbase I loaded on the remote laptop, it was created as part of a synch set. It has a password but I don't remember what it is all the time. This is the one I'm trying to work with.

 

Below is some of my sync settings from the host computer (TIBERIUS)

 

ACT_synch-settings2.jpg

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: unable to sych database, apparently unable to start "Accept Incoming Sychs"

When attempting to start the 'accept incoming syncs', if you are getting the window that contains the port number - try changing the port number to 65200 or 65300.  Will the service start?  If yes, you would just need to change the port in the remote to establish the connection.

 

Here is an article which addresses the error 'SQL Database instance is unavailable': KB Article 25726

Since it is the publisher database that won't start the 'accept incoming syncs' option, use the steps titled:

- Disabled SQL Server Protocols

- Detach and Reattach Database from SQL Server

 

If it still will not start, open the Demo database and attempt to set up sync.  Will the 'accept incoming syncs' start in the demo?  If no, it points to an issue with SQL Server.  If yes, it points to an issue/setting within the original publisher database.

Greg Martin
Sage
Astute Commentator
Posts: 17
Country: USA

Re: unable to sync database, "Accept Incoming Syncs" & all diags look good

[ Edited ]

Have changed ports to 65200 and 65300 on both server and client no difference have reset both back to 65100.  When I change the port# on the client, the Server computer posts the usual "SQL DataBase instance is unavailable" bit.  Thus it appears the 2 computers are communicating.  Ran the SQL manager and all the named pipes & such are on and everything seems okay there.

 

Have opened the Demo databases on the Publisher DBase and will "Accept Incoming Syncs". Thus it appears the SQL Server is okay. 

 

Troubleshot and made sure that Publisher and Subscriber? or Remote computer names are correct.  Deleted all sync sets and created a new sync set with a new remote database.

 

Ran ACTDIAG on the server (Publisher) and unattached and reattached the database. Ran ACTDIAG on subscriber (remote) and that Database is set to sync.

 

Still have "ACT is unable to connect to the sync server" issue.  OS for both computers is Windows-7 Pro 32bit, ACT is v 2012.