Community
Showing results for 
Search instead for 
Do you mean 
Reply

"Object has been deleted" when loading Mail Merge

New Member
Posts: 4
Country: United States

"Object has been deleted" when loading Mail Merge

Hi all,

 

When I attempt to do a Mail Merge, using any document template and using any Lookup, I am getting a "Object Has Been Deleted" error almost immediately after it starts to load the merge.  HELP!!

 

Thanks!

 

Luke

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: "Object has been deleted" when loading Mail Merge

Luke,

Can you provide some additional information:

- Version of Act!

- Are you using Microsoft as your Word Processor program or the Act! Word Processor?

 If using MS Word, what is the version of Office?

- Operating System

- Is the Mail Merge to an Email or to a Document? 

 

Greg Martin
Sage
New Member
Posts: 4
Country: United States

Re: "Object has been deleted" when loading Mail Merge

Thanks for the quick reply Greg!

 

answers to your questions:

ACT! 2010

Microsoft Word- Office 2007

Windows Vista 32-bit

Mail merge to document

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: "Object has been deleted" when loading Mail Merge

2 things to try:

1. Run Act! as an Administrator.  To do this: close Act! > right click on Act! icon > select 'Run As Administrator'.  Test again.

2. Try the Act!Demo database to see if the error also occurs there.

 

You mentioned it happens with any template and any Lookup:

- Have you tried to a single Contact (use the Current Contact option)?

- What happens if you use the Write > Other Document > select template process?

 

 

Greg Martin
Sage
New Member
Posts: 4
Country: United States

Re: "Object has been deleted" when loading Mail Merge

Greg,

 

I was going through the fixes that you suggested, when I realized that I did not receive the error when merging all documents...it just so happened that the few I had attempted to merge all gave me the same error.  So I went to those documents specifically and found that there was an invalid merge field included in them, and when I removed that field, they merge no problem.

 

THANK YOU for your help on this!

 

Unfortunately I have another issue that has popped up- when I insert the <Letter Date> field into the body of the letter (using MS Word), the date does not print and the field does not even show at all when merging.  Can you help me with this one?  All I want to do is print today's date on the letters.

 

Thanks again,

 

Luke

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: "Object has been deleted" when loading Mail Merge

Hello Luke,

That field is comming up blank because at the point you are doing the merge, no value has been generated for that field. If you want todays date on the letter, the best thing is to use MS Word's insert date field function to place the current date.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 4
Country: United States

Re: "Object has been deleted" when loading Mail Merge

Ok.  I went ahead and just typed in manually the date since I'm creating this file of letters to be sent tomorrow.  So my next question would be- how would that field be populated with data so that it would show up?

 

thanks again,

 

Luke

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: "Object has been deleted" when loading Mail Merge

Since you are editing the template in MS Word, you can add a date field through Word that will populate with the current date when you merge to that template. From the ribbon at the top of Word 2007, click the Insert tab, then click Date & Time, choose your format, make sure the "Update automatically" box is checked and click OK.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.