Community
Showing results for 
Search instead for 
Do you mean 
Reply

"Object Reference" error when creating a new company

Accepted Solution Solved
New Member
Posts: 2
Country: USA
Accepted Solution

"Object Reference" error when creating a new company

Using ACT Pro 2012 (14.1.108.0) on a db converted and imported from a 2007 system at a former sister company. Any time a new company is created we get the popup error "object reference not set to an instance of an object". I've reviewed the kb article that lists a dozen or so causes, sadly none of them directly applied to this issue. I've run the db check and repair utlities with no change. Also tried performing a "save copy as" to a new db, both as a full copy and as an empty copy. Neither corrected the error.

 

I have been able to create companies in a new blank database without issue, so I don't believe it's the application itself.

 

Any thoughts on how I can correct the misconfiguration in the database that is causing this?

 

Thanks,

-Eric


Accepted Solutions
Solution
Accepted by topic author erichards_flr
‎09-25-2015 03:20 AM
Silver Super Contributor
Posts: 2,328
Country: USA

Re: "Object Reference" error when creating a new company

Check the duplicate checking for Companies in Tools | Preferences on the Admin tab and make sure it is valid.  If that isn't it you'll probably have to get someone who is familiar with troubleshooting an ACT! database to find the problem for you.  I can do it.  Contact me offline if you'd like me to see if I can fix it for you.


Stan


If you would like to get more out of ACT! you can find an ACT! Certified Consultant near you by going to:www.act.com/acc.
-------------------------------------------------------------------------------------
Stan Smith
ACT! Certified Consultant
ADS Programming Services, Inc.
(205) 222-1661
www.adsprogramming.com
www.actwebhosting.com
Click Here to Purchase Act!

View solution in original post


All Replies
Solution
Accepted by topic author erichards_flr
‎09-25-2015 03:20 AM
Silver Super Contributor
Posts: 2,328
Country: USA

Re: "Object Reference" error when creating a new company

Check the duplicate checking for Companies in Tools | Preferences on the Admin tab and make sure it is valid.  If that isn't it you'll probably have to get someone who is familiar with troubleshooting an ACT! database to find the problem for you.  I can do it.  Contact me offline if you'd like me to see if I can fix it for you.


Stan


If you would like to get more out of ACT! you can find an ACT! Certified Consultant near you by going to:www.act.com/acc.
-------------------------------------------------------------------------------------
Stan Smith
ACT! Certified Consultant
ADS Programming Services, Inc.
(205) 222-1661
www.adsprogramming.com
www.actwebhosting.com
Click Here to Purchase Act!
New Member
Posts: 2
Country: USA

Re: "Object Reference" error when creating a new company

That was it! If only you knew how many kb articles and forum posts I dug through for a simple checkbox.

 

Thanks!

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: "Object Reference" error when creating a new company

Glad to hear your issue has been resolved!

 

For other members reviewing this post, the article that addresses this issue: KB Article 28627

Greg Martin
Sage