Community
Showing results for 
Search instead for 
Do you mean 
Reply

database could not be accessed.

Accepted Solution Solved
Tuned Listener
Posts: 32
Country: Canada
Accepted Solution

database could not be accessed.

I have looked through the forums and I have yet to Find a solution.

 

I had to move the main database on our server because of the default location "My documents" added few folders that created too long pathname and gave me error.

 

Before I do the drag and drop of the databases, I have stoped Act7 service and restarted it afterwards.

 

I have highlighted all for file for the database and went into the properties to remove the checkmark in "Archive" as it compress the files.

 

I am not able to start the database locally, so firewall and network as nothing to do here. (Also tried to to stop my Anti-virus juste in case(Kaspersky))

 

Anyone have any Idea?


Accepted Solutions
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: database could not be accessed.

Since you moved your database, the PAD file will no longer be valid (it will reference the previous location). 

First, ensure your database is detached from SQL through Actdiag:

- Windows Start button > Run (XP) or Search (Vista/Win7) > enter command 'actdiag'

(or double click on file at: C:\program files\act\act for windows\actdiag.exe)

- When the Diagnostics program opens > click on the word Databases in the left column > then select Database List

- in the list on the right, do you see your database name?  Is the Status Online or Recover?

- left click on the gray square to the left of the database name to highlight the line > you can scroll right to verify the location still refers to the original path.

- right click on the database name and select the option that is available: Detach Database (if Status is Online) or Delete Database (if Status is Recover).

Note: If Delete is the available option > make sure you scroll right and verify the location that it lists for the database is the original location, so that it will not be attempting to remove the database from it's new location.

 

To open your database and create a new PAD file:

- delete the original PAD file (databasename.pad) - this will have no affect on the data within the database

- open Act! program > select File > select Open Database

- change 'Files of Type' to *.ADF

- browse to the location of your database and select the 'databasename.adf' file

Greg Martin
Sage

View solution in original post


All Replies
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: database could not be accessed.

Since you moved your database, the PAD file will no longer be valid (it will reference the previous location). 

First, ensure your database is detached from SQL through Actdiag:

- Windows Start button > Run (XP) or Search (Vista/Win7) > enter command 'actdiag'

(or double click on file at: C:\program files\act\act for windows\actdiag.exe)

- When the Diagnostics program opens > click on the word Databases in the left column > then select Database List

- in the list on the right, do you see your database name?  Is the Status Online or Recover?

- left click on the gray square to the left of the database name to highlight the line > you can scroll right to verify the location still refers to the original path.

- right click on the database name and select the option that is available: Detach Database (if Status is Online) or Delete Database (if Status is Recover).

Note: If Delete is the available option > make sure you scroll right and verify the location that it lists for the database is the original location, so that it will not be attempting to remove the database from it's new location.

 

To open your database and create a new PAD file:

- delete the original PAD file (databasename.pad) - this will have no affect on the data within the database

- open Act! program > select File > select Open Database

- change 'Files of Type' to *.ADF

- browse to the location of your database and select the 'databasename.adf' file

Greg Martin
Sage
Tuned Listener
Posts: 32
Country: Canada

Re: database could not be accessed.

Thanks much,

 

It fixed it!

 

 

New Member
Posts: 12
Country: United States

Re: database could not be accessed.

Hi.

 

I'm having the same problem of being unable to access my data base.  I did the actdiag you suggested.  The data base was under 'Recover".  I didn't delete it as you suggested because I don't have a copy of the data base, except for carbonite.  I tried to repair.. but it said they coulldn't locate the file.

 

I think I screwed things up because earlier I attempted to clean my computer by trying to delete C:\windows\temp files, any file over one day old and also C:\ *.tmp over one day old.  Some folders were locked, but I can't say that some files were not delete.  I attempted to restore the files out of the recycle bin but couldn't find any there.

 

Another situation is that I can find *.ADF and *.pad files using windows explorer but cannot locate them when using Act! file open.

 

I'm not sure what to do... Would doing a restore from Carbonite correct everything?  maybe to a different folder?  Very frustrating.

 

roger