Community
Showing results for 
Search instead for 
Do you mean 
Reply

adf files must be on a local device. Files on mapped or shared drives cannot be used

Accepted Solution Solved
New Member
Posts: 3
Country: United States
Accepted Solution

adf files must be on a local device. Files on mapped or shared drives cannot be used

I am getting the following message when trying to share my ACT! DB.  "adf files must be on a local device.  Files on mapped or shared drives cannot be used"  I first created the db on my laptop while waiting for our new server to come in.  Once the server came in I installed a copy of ACT on it and copied the database file to the new machine.  I am able to access the db on the server, but not on my laptop.   I have a 5 user pack of ACT 2007 and have a copy installed on the server and on my laptop and have three user ids created.  Both machines are running XP Pro.  Little help here.

Thanks,

Trey


Accepted Solutions
Solution
Accepted by topic author treymcl1
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: adf files must be on a local device. Files on mapped or shared drives cannot be used

This error will occur when you try to open an .adf file through a network drive. ACT! database should be opened using the .pad file.  It sounds as though the .pad file may have invalid database location information in them.  I would suggest:

1) Have all users exit the database

2) Go to server, go to Start/Run, type in "actdiag" to start ACT! Diagnostics

3) On the left, Databases and go to the Database List

4) Click on your database to highlight it, then right click and choose Detach Database..click Yes to agree.  The database will disappear from the list.  Close ACT! Diagnostics

5) Open Windows Explorer (or My Computer) and browse to the physical location (not the network location) of the database

6) Delete the .pad file for the database

7) Open ACT! locally on the server..you should get a message that the last database cannot be opened and then get the Open database screen

8) Change the Files of Type dropdown on the screen from .pad to .adf, browse the .adf file for your database and double-click to open

9) Follow the prompts to update/attach the database.  This creates a new .pad file.

 

Going forward you would use this .pad file to open the database.  You can make a copy of this .pad file (only this file) and put on your desktop for east access to the server database.

 

treymcl1:

If you have a copy of this database on your machine, it is technically a different database than the one on the server, so would have a different .pad file. 

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

View solution in original post


All Replies
New Member
Posts: 2
Country: United States

Re: adf files must be on a local device. Files on mapped or shared drives cannot be used

Did you get any where with this? I get the same error on a workstation when trying to access the database on the server via UNC or a mapped drive.

 

-Seth

Solution
Accepted by topic author treymcl1
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: adf files must be on a local device. Files on mapped or shared drives cannot be used

This error will occur when you try to open an .adf file through a network drive. ACT! database should be opened using the .pad file.  It sounds as though the .pad file may have invalid database location information in them.  I would suggest:

1) Have all users exit the database

2) Go to server, go to Start/Run, type in "actdiag" to start ACT! Diagnostics

3) On the left, Databases and go to the Database List

4) Click on your database to highlight it, then right click and choose Detach Database..click Yes to agree.  The database will disappear from the list.  Close ACT! Diagnostics

5) Open Windows Explorer (or My Computer) and browse to the physical location (not the network location) of the database

6) Delete the .pad file for the database

7) Open ACT! locally on the server..you should get a message that the last database cannot be opened and then get the Open database screen

8) Change the Files of Type dropdown on the screen from .pad to .adf, browse the .adf file for your database and double-click to open

9) Follow the prompts to update/attach the database.  This creates a new .pad file.

 

Going forward you would use this .pad file to open the database.  You can make a copy of this .pad file (only this file) and put on your desktop for east access to the server database.

 

treymcl1:

If you have a copy of this database on your machine, it is technically a different database than the one on the server, so would have a different .pad file. 

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 2
Country: United States

Re: adf files must be on a local device. Files on mapped or shared drives cannot be used

Awesome! Works perfectly now. And now I have a better understanding of how this whole thing works.

 

Thanks.

New Member
Posts: 3
Country: United States

Re: adf files must be on a local device. Files on mapped or shared drives cannot be used

Thanks again for your help, but this did not work.  When I delete the .pad file and then open ACT! on the server I get a message that says "ACT! will now verify the database.  This process may take several minutes."  It then opens the same database and I still cannot access it on my laptop.  What am I missing? 
New Member
Posts: 3
Country: United States

Re: adf files must be on a local device. Files on mapped or shared drives cannot be used

Please disregard the last post.  I got it working.  Thanks for all your help.

Trey

Copper Contributor
Posts: 48
Country: USA

Re: adf files must be on a local device. Files on mapped or shared drives cannot be used

I'm not sure I understand this. I pointed to the drive as server\share and it still won't open the adf.  And if I do it locally, I'm still running the local version.  Sorry to be so stupid, but can we go over this again?  Do I have to run the ADF from the server drive directly? I don't have access for that.

Bronze Super Contributor
Posts: 1,543
Country: United_Kingdom

Re: adf files must be on a local device. Files on mapped or shared drives cannot be used

Hi Janet,

 

I'm wondering if you should check the following:

 

Ensure that the Named Pipes and TCP/IP Protocols are enabled. Use the following Steps:

  1. Click the Windows Start button, point to All Programs (or Programs), point to Microsoft SQL Server 2005, point toConfiguration Tools, and then click the SQL Server Configuration Manager option. The SQL Server Configuration Manager dialog box appears.



  2. Expand the SQL Server 2005 Network Configuration entry in the left panel, and then click the Protocols for ACT7.
  3. Locate the Named Pipes entry from the Protocols Name column in the right-pane. If the Status column does not display Enabled, right-click the entry, and then click Enable from the shortcut menu.
  4. Locate the TCP/IP entry from the Protocols Name column in the right-pane. If the Status column does not displayEnabled, right-click the entry, and then click Enable from the shortcut menu, otherwise close the SQL Server Configuration Manager dialog box.

David Shaw
Act! Certified Consultant since 2001
Office:    +44 (0)1483 714507
Mobile: +44 (0)7977 567 318
E-Mail:    dshaw@act4u.org 
Copper Contributor
Posts: 48
Country: USA

Re: adf files must be on a local device. Files on mapped or shared drives cannot be used

Thanks, David.  I'll try this and get back to you...