Community
Showing results for 
Search instead for 
Do you mean 
Reply

actdiag not working - object reference not set problem

Copper Contributor
Posts: 66
Country: USA

actdiag not working - object reference not set problem

In the course of trying to open a remote database file to restore in on the remote Win10 computer (ACT! v18 Pro hotfix 4 I believe) I am getting nullstring errors in ACTDIAG. I can't do anything with the databases listed, so I can't fix my problem opening the database.

here's the error detail I get from the dialog box:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at ActDiag.Database.get_IsLocked()
at ActDiag.DatabaseCollection.ړ(Object Ԗ, EventArgs ԗ)
at System.Windows.Forms.ContextMenu.OnPopup(EventArgs e)
at System.Windows.Forms.ContextMenu.Show(Control control, Point pos, Int32 flags)
at System.Windows.Forms.ContextMenu.Show(Control control, Point pos)
at System.Windows.Forms.Control.WmContextMenu(Message& m, Control sourceControl)
at System.Windows.Forms.Control.WmContextMenu(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1063.1 built by: NETFXREL3STAGE
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
ActDiag
Assembly Version: 18.0.501.0
Win32 Version: 18.0.501.0
CodeBase: file:///C:/Program%20Files%20(x86)/ACT/Act%20for%20Windows/ActDiag.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Data
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Transactions
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.EnterpriseServices
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
----------------------------------------
Accessibility
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.Numerics
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1038.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

 

Any help would be appreciated. thank you

Administrator
Posts: 4,024
Country: United_Kingdom

Re: actdiag not working - object reference not set problem

Hi There,

There are a number of suggested solutions for this scenario in the following Knowledgebase article:
http://kb.swiftpage.com/app/answers/detail/a_id/38189

Please let us know how you get on.
Copper Contributor
Posts: 66
Country: USA

Re: actdiag not working - object reference not set problem

via ACTDiag I can see and work with the test database i created. The issue is, I can't delete the other ones in the list of databases. They don't exist, but ACTDIAG seems to think they do.

Administrator
Posts: 4,024
Country: United_Kingdom

Re: actdiag not working - object reference not set problem

I've spoken to people who have had success in solving this issue by reinstalling SQL.
Copper Contributor
Posts: 66
Country: USA

Re: actdiag not working - object reference not set problem

yeah, I did that last night, removed everything (including SQL) and reinstalled from the beginning. When deleting a database, need to detach it first (which I've now learned) from SQL.

Administrator
Posts: 4,024
Country: United_Kingdom

Re: actdiag not working - object reference not set problem

Has the issue now been resolved?
Copper Contributor
Posts: 66
Country: USA

Re: actdiag not working - object reference not set problem

yup