Community
Showing results for 
Search instead for 
Do you mean 
Reply

Yet another SQL Server issue with Act! 2011

New Member
Posts: 9
Country: USA

Yet another SQL Server issue with Act! 2011

[ Edited ]

Just like the writer below (CDuarte, originally posted 9/30/10), my problem is not resolvable...at least to me. I must have received a Windows Update to my SQL Server, as it would not launch yesterday after previously running well (I have since changed Windows Update to "custom" so I can control (ie, ignore) any updates to the SQL server).

 

To summarize, when launched, Act! claims it cannot connect to the database. I run services.msc in the Start/Search box, right click SQL Server Act 7, then I can open my database and all is right with the world. Except...I have to do this EACH DAY wehen I start up the computer.

 

So this is not a permanet solution. I paid too much to live with this work-around; I would like an answer to getting this corrected once and for all.

 

TIA.

 

Nickel Elite Contributor
Posts: 508
Country: USA

Re: Yet another SQL Server issue with Act! 2011

I bet that update did not install correctly, and every night is attempting to reinstall, and in the process is turning off SQL Server.  Can you go into the Automatic Updates "program" interface and see if there's an update that's been downloaded, but not installed?

Richard Brust
ACT! Certified Consultant
richard@rbrDataSolutions.com
New Member
Posts: 9
Country: USA

Re: Yet another SQL Server issue with Act! 2011

All updates are listed as successful...and none have SQL Server in the header. Thks for the thought though.

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Yet another SQL Server issue with Act! 2011

Hello Stufis,

Welcome to the ACT! Online Community!

 

If you are rebooting your computer each night - look in the Services window and make sure that the SQL Server (ACT7) service is set to 'Automatic' in the 'Startup Type'.

Greg Martin
Sage
New Member
Posts: 9
Country: USA

Re: Yet another SQL Server issue with Act! 2011

Greg- Automatic is already set...but it's a new year,,,and it has decided to work this time when I booted up.

I'll re-boot again (I do that a couple of times a week...that's all) and see if it behaves.
New Member
Posts: 9
Country: USA

Re: Yet another SQL Server issue with Act! 2011

it stopped playing nice...when I reboot, I have to manually start SQL Service in service.msc...even tho' it sez "automatic."

 

Thoughts?

Nickel Elite Contributor
Posts: 508
Country: USA

Re: Yet another SQL Server issue with Act! 2011

Check the Windows Logs>Application under Event Viewer (in Administration Tools) just in case - this may tell you if there is an error.  Look for entries with SQL Server - like MSSQL$ACT7 and/or SQLBrowser...

Richard Brust
ACT! Certified Consultant
richard@rbrDataSolutions.com
New Member
Posts: 9
Country: USA

Re: Yet another SQL Server issue with Act! 2011

Thanks for the responce...It indeed shows an error msg...buried in the middle of this string...niot knowing what to look for, I provided the entire sequence...it shows at the end that my manual intervention opened the db.

 

Starting up database 'model'.

Server name is 'STU-PC\ACT7'. This is an informational message only. No user action is required.

Starting up database 'msdb'.

A self-generated certificate was successfully loaded for encryption.

Server is listening on [ 'any' <ipv6> 49212].

Server is listening on [ 'any' <ipv4> 49212].

Server local connection provider is ready to accept connection on [ \\.\pipe\SQLLocal\ACT7 ].

Server named pipe provider is ready to accept connection on [ \\.\pipe\MSSQL$ACT7\sql\query ].

Dedicated administrator connection support was not started because it is disabled on this edition of SQL Server. If you want to use a dedicated administrator connection, restart SQL Server using the trace flag 7806. This is an informational message only. No user action is required.

Clearing tempdb database.

The SQL Server Network Interface library could not register the Service Principal Name (SPN) for the SQL Server service. Error: 0x54b, state: 3. Failure to register an SPN may cause integrated authentication to fall back to NTLM instead of Kerberos. This is an informational message. Further action is only required if Kerberos authentication is required by authentication policies.

SQL Server is now ready for client connections. This is an informational message; no user action is required.

Starting up database 'tempdb'.

The Service Broker protocol transport is disabled or not configured.

The Database Mirroring protocol transport is disabled or not configured.

Service Broker manager has started.

Recovery is complete. This is an informational message only. No user action is required.

Launched startup procedure 'PRC_MASTER_AUTOSTARTUPS'.

Starting up database 'restored121810'.

New Member
Posts: 9
Country: USA

Re: Yet another SQL Server issue with Act! 2011

BTW, I see in services.msc that SQL Service Agent (ACT7) is disabled. No one has mentioned if Agent should be enabled...
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Yet another SQL Server issue with Act! 2011

If you have a Vista or Windows 7 operating system there is a setting for the service for 'Automatic (Delayed Start)' > try changing the Startup Type to this delayed setting to see if that will resolve the issue.

 

We don't want the 'Sql Service Agent (Act7)' service started.

 

 

Greg Martin
Sage