Community
Showing results for 
Search instead for 
Do you mean 
Reply

When editing, Customized Field Behavior "use drop down list" is grayed out.

Accepted Solution Solved
New Member
Posts: 12
Country: United States
Accepted Solution

When editing, Customized Field Behavior "use drop down list" is grayed out.

Hello,

 

When editing, Customized Field Behavior "use drop down list" is grayed out.  I also note that 'Select a field data type' is memo and the other fields that have drop down is "Character", which may have something to do with it.  However, the only select option for that field is 'memo' and I cannot change that, if that is what is required to have the 'use drop down list' not to be grayed out.

 

Can't find any help in the Act! Manual.

 

I have Act!2010 version 12.1.181.0.  Hot Fix 1

 

Thanks.


Accepted Solutions
Solution
Accepted by topic author Stealth007
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: When editing, Customized Field Behavior "use drop down list" is grayed out.

Unfortunately the the Edit > Copy Field option won't copy from a Memo field to a character field or this would be very easy.  The 2 options available will be 1. Manually copy information, or 2. Use Import function.

 

Option 1: Depending on how many contacts have information in the memo field - you may be albe to update your new field manually.

 

Option 2: Customize the columns on the Contact List view to only include Contact, Phone, Company, Address, and the Memo field (Contact, Phone, Company, Address being listed as possible fields to use for Duplicate Checking).  With columns set > select the Export to Excel icon to create an Excel file which can then be save as an CSV file.  Within this file, go ahead and change the column heading for the Memo field to match the name of your Character field.

Then use the File > Import process to import the updated information.  Use the Merge option so that it will update only the empty field (the character field).

Note: Before making mass changes or running an import - ALWAYS create a backup of your database (File > Backup > Database) in case the results are not as expected.

 

Here is an article with instructions for importing a CSV file - also contains instructions for setting Duplicate Checking: KB Article 15208

 

 

 

 

Greg Martin
Sage

View solution in original post


All Replies
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: When editing, Customized Field Behavior "use drop down list" is grayed out.

You are correct about the type being 'Memo' - memo fields cannot use a drop-down list.  You also cannot convert a Memo field to Character (which allows the drop-down), you will need to create a new field as Character and then select Use Drop-Down List.

Greg Martin
Sage
New Member
Posts: 12
Country: United States

Re: When editing, Customized Field Behavior "use drop down list" is grayed out.

Thanks Greg.  Do you think this work around would work?  I have a lot of data in the 'memo' field that I do not wish to lose.  If I create a Character field with a drop down, transfer all the data from the memo to the new field, and then delete the original memo field, would I lose any data or create any problems?  I imagine I will have to edit all of my templates that uses the field.  Can you anticipate any other problems?

 

Thanks.

Solution
Accepted by topic author Stealth007
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: When editing, Customized Field Behavior "use drop down list" is grayed out.

Unfortunately the the Edit > Copy Field option won't copy from a Memo field to a character field or this would be very easy.  The 2 options available will be 1. Manually copy information, or 2. Use Import function.

 

Option 1: Depending on how many contacts have information in the memo field - you may be albe to update your new field manually.

 

Option 2: Customize the columns on the Contact List view to only include Contact, Phone, Company, Address, and the Memo field (Contact, Phone, Company, Address being listed as possible fields to use for Duplicate Checking).  With columns set > select the Export to Excel icon to create an Excel file which can then be save as an CSV file.  Within this file, go ahead and change the column heading for the Memo field to match the name of your Character field.

Then use the File > Import process to import the updated information.  Use the Merge option so that it will update only the empty field (the character field).

Note: Before making mass changes or running an import - ALWAYS create a backup of your database (File > Backup > Database) in case the results are not as expected.

 

Here is an article with instructions for importing a CSV file - also contains instructions for setting Duplicate Checking: KB Article 15208

 

 

 

 

Greg Martin
Sage
New Member
Posts: 12
Country: United States

Re: When editing, Customized Field Behavior "use drop down list" is grayed out.

OK.  I can do that.  Can a Character field, with drop down, have word wrap?  Is that the major difference field types, word wrap vs drop down?  You can't have both?

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: When editing, Customized Field Behavior "use drop down list" is grayed out.

No - can't have a drop down with word-wrap. A memo field is the only type that will do wrapping of text. All others will continue out to the right without wrapping.
Greg Martin
Sage