Community
Showing results for 
Search instead for 
Do you mean 
Reply

Vista:you don't have permission to open this file

Accepted Solution Solved
Copper Contributor
Posts: 54
Country: United States
Accepted Solution

Vista:you don't have permission to open this file

Hi,

 

I'm trying to help my business partner set up his upgrade of Act 2010 using remote assist software. Yesterday, I created an empty copy of his database to a folder on his desktop so that I could email it to myself, work on it, then send it back to him. When I try to email it (or send it via a large file sharing service on the internet) each time I try to access one of the files I get the message "you don't have permission to open this file". The users logged in is the administrator and was such when the files were created. It's a one-user computer. So, is this something to do with the SQL software? Any thoughts on a fix? I've tried going to properties, security, owner, etc. etc. and he is shown as the administrator.

 

Thanks,

 

Dan

VISTA - ACT2010 single user, hotfix4


Accepted Solutions
Solution
Accepted by topic author dbish
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Vista:you don't have permission to open this file

You can get SQL to release the files by stopping the 'SQL Server (Act7)' service.  While the service is stopped you will not be able to access your database through the Act! program, but you will be able to copy the files.

Steps:

- Close Act! 

 

- On XP > Windows Start button > select RUN > enter 'Services.msc' and click OK.

- On Vista/Win7 > Windows Start button > in the Search area enter 'Services.msc' > hit enter key

 

On the Services screen:

- scroll down to 'SQL Server (Act7)' > click on it to highlight it

- right click on it and select 'Stop'

.... copy your files

- to restart the service > right click on 'SQL Server (Act7)' > select 'Start'

 

You can now reopen Act!

 

 

Greg Martin
Sage

View solution in original post


All Replies
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Vista:you don't have permission to open this file

The SQL program does 'lock' the files and prevent access from copying/moving them.  The best method for moving a database is to use the backup and restore functions.  You will need to open the Empty Copy database to run the backup process, it will create a zip file you can then transfer to the other computer to be restored (use the 'Restore As' option). 

How to Backup and Restore an Act! database

Greg Martin
Sage
Copper Contributor
Posts: 54
Country: United States

Re: Vista:you don't have permission to open this file

Hi Greg,

 

Thanks for that - I suppose backup/restore should work just as well - I'll give it a try.

 

Dan

Copper Contributor
Posts: 54
Country: United States

Re: Vista:you don't have permission to open this file

Greg, Is there any way to work around these SQL file permission issues? I'm trying to help an associate rework his database to match mine, then want to send it back to him. Without permission (even though I'm the administrator), I'm pretty sure I'm not going to be able to zip it and send it to him, nor will he be able to access it when he gets it. Any thoughts? Thanks, Dan
Solution
Accepted by topic author dbish
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Vista:you don't have permission to open this file

You can get SQL to release the files by stopping the 'SQL Server (Act7)' service.  While the service is stopped you will not be able to access your database through the Act! program, but you will be able to copy the files.

Steps:

- Close Act! 

 

- On XP > Windows Start button > select RUN > enter 'Services.msc' and click OK.

- On Vista/Win7 > Windows Start button > in the Search area enter 'Services.msc' > hit enter key

 

On the Services screen:

- scroll down to 'SQL Server (Act7)' > click on it to highlight it

- right click on it and select 'Stop'

.... copy your files

- to restart the service > right click on 'SQL Server (Act7)' > select 'Start'

 

You can now reopen Act!

 

 

Greg Martin
Sage