Community
Showing results for 
Search instead for 
Do you mean 
Reply

Upgrading from 2010 12.0 to 2010 12.1 causes "Failed to open rowset"

New Member
Posts: 4
Country: United States

Upgrading from 2010 12.0 to 2010 12.1 causes "Failed to open rowset"

We upgraded to 2010 12.1 and now our custom crystal report (call reports based on activity/notes by group) gives a :

 

Failed to open a rowset

Details: ADO Error Code: 0x0

Source: ACT! OleDB Provider for reporting 2.0

Description: Invalid object name '#GROUP_CONTACT'.

SQL State:

Native Error: -2147217865

 

Any help would be much appreciated.

Bronze Super Contributor
Posts: 1,170
Country: USA

Re: Upgrading from 2010 12.0 to 2010 12.1 causes "Failed to open rowset"

There doesn't appear to be anything in the Act! support database that exactly matches this.

 

Can you create a copy of the report file and then edit it and work through re-establishing/mapping the data source and see if that fixes the issue?

New Member
Posts: 4
Country: United States

Re: Upgrading from 2010 12.0 to 2010 12.1 causes "Failed to open rowset"

Thank You for the quick reply.

 

If I understood correctly...

 

I made a copy of one of the reports, then went to "Set datasource location" and re-mapped all the fields.

 

Result was the same error at the same point in the report.

New Member
Posts: 4
Country: United States

Re: Upgrading from 2010 12.0 to 2010 12.1 causes "Failed to open rowset"

Update 1:

 

The error has been isolated to a subreport that deals with the Activity tables. Removing the subreport allows the original report to run.

 

The subreport isolated gives the same error message.

 

I have re-linked the sub-report tables and remain baffled.