Community
Showing results for 
Search instead for 
Do you mean 
Reply

Upgrade 16.2 STILL doesn't work with Google Calendar

Copper Contributor
Posts: 44
Country: USA

Upgrade 16.2 STILL doesn't work with Google Calendar

I just upgraded to Act! Pro Version 16.2.14.0 with high hopes that the broken synchronization to Google Calendar, which is important to me and a lot of people, would finally work again after more than six months.

 

I tried to reset up the synchronization protocols and got this message from the Google authorization service.

 

"You’re being redirected to this article because the application you’re using uses OAuth 1.0, and we only support the newer OAuth 2.0 at this time. 

 

You can either contact the owner of the third-party application you're using for more information or you can switch to a new service that does use OAuth 2.0. We realize this isn't an optimal solution, but, ultimately, Google can't force any developers to make changes to their products. 

 

Is there something I'm missing here?   It would appear that we have waited more than six months for this fix in vain!  What is the deal, Swiftpage?  Why can't you get this right?

Copper Contributor
Posts: 81
Country: USA

Re: Upgrade 16.2 STILL doesn't work with Google Calendar

There is a newer service pack available, released 2/25/2015.  

 

version 16.3 seems to have fixed the Google problem.  Try applying that patch - US version available here: http://cdn.act.dlm.swiftpage.com/3617/act_pro16_sp3x11_us_update.exe

 

Keep in mind that with a service pack update, you'll need to update every computer to be on the same version.  Apply it on the server first.

Twelve/Three Marketing, Inc.
Act! Certified Consultants
......Stephen Boulden
Twelve/Three Marketing, Inc.
P: 716.837.5727 x104
E: stephen@twelvethree.com
Copper Contributor
Posts: 44
Country: USA

Re: Upgrade 16.2 STILL doesn't work with Google Calendar

Thank you.  Sync seems to now be working after this Service Pack upgrade.

 

However, when I manually sync, I get the message, "You must select integration preferences before you can synchronize your Act! and Google calendar."  This inspite of the fact that I have set those preferences.  If I click "Yes", I then get the message "Google integration requires an update to .NET 4.0.  Do you want to learn more?" 

 

I have followed instructions to update to .NET 4.0 and each time I attempt that, it tells me that "KB2468871v2 does not apply, or is blocked by another condition on your computer."

 

I have confirmed that .NET 4.0 is installed on my computer.  There seems to be no way to upgrade it, and if I don't upgrade it, I have to go through this extra process every time I want to sync.

 

Suggestions?

 

 

Copper Contributor
Posts: 81
Country: USA

Re: Upgrade 16.2 STILL doesn't work with Google Calendar

Yeah, I've run into that .NET problem recently.  Go check in your installed programs - odds are, you have .NET 4.5, instead of 4.0.

 

It's very silly that Act is finnicky and doesn't want to work with .NET 4.5, considering that the v16.0 installer is what put 4.5 on there in the first place.  In later act installer versions (such as v16.3 and v17), they reverted back to 4.0, so if there is no .NET detected then you get 4.0 instead of 4.5.

 

Anyways, your options at this point... back up your database first!

 

1.  You can try a preferences reset via actdiag.exe, though I suspect this might not fix it

 

2.  You can try the "Repair" option for .NET in your control panel programs

 

3.  Full nuclear option.  At some point you'll actually save some time going this route, rather than wasting an afternoon trying to avoid it.  First create backups / system restore points. Completely uninstall Act, uninstall all .NET Frameworks.  Reboot the computer.  Reinstall act using the 16.3 installer I linked you earlier.  Act will re-download the proper version of .NET 4.0 this time and it all should work.  Your database, layouts, and templates should be unaffected by this, but make those backups anyway!  You'll need to reconfigure your preferences and minor customizations.

 

Anyone else, feel free to step in with a better suggestion.  Personally I would just take the full nuclear route right off the get go because I am certain that it will work.  There could be a way to fix it without the full uninstall of Act and .NET, but I would be concerned that you may end up spending more time (and money) trying to figure that out in the end.

 

Also throwing this out there - I work for an independent Act consultant company based in Buffalo NY, we are Twelve/Three Marketing, and you can call my number for support, purchases, & questions.

Twelve/Three Marketing, Inc.
Act! Certified Consultants
......Stephen Boulden
Twelve/Three Marketing, Inc.
P: 716.837.5727 x104
E: stephen@twelvethree.com
Copper Contributor
Posts: 44
Country: USA

Re: Upgrade 16.2 STILL doesn't work with Google Calendar

The strange thing is....in the "Programs and Features", there is no Microsoft .Net 4 or 4.5 listed.  So I can't do a repair.  Yet clearly it is installed or Act wouldn't be functioning at all (I think). 

New Member
Posts: 9
Country: Australia

Re: Upgrade 16.2 STILL doesn't work with Google Calendar

Is there a service pack for Australia or do I use the one above?
Administrator
Posts: 4,024
Country: United_Kingdom

Re: Upgrade 16.2 STILL doesn't work with Google Calendar

Here are the Australian specific service packs:

Pro v16.3 update

Premium v16.3 update

New Member
Posts: 21
Country: Netherlands

Re: Upgrade 16.2 STILL doesn't work with Google Calendar

Hello,

 

Is there a EU fix to re-connect Act with Google?


According Act update I do have the latest version of Act Pro, 16.2.14.0, Hot Fix 1.

But still when I try to connect Google i receve the message to migrate to OAuth 2.0.

 

Is there update or hotfix which I should use to get connected again to google to synchronize my contacts and calendar.

 

Any help or suggestions are very welcome,

 

Cheers

 

Marc

Administrator
Posts: 4,024
Country: United_Kingdom

Re: Upgrade 16.2 STILL doesn't work with Google Calendar

[ Edited ]

Hi Marc.

The latest version of Act v16 is 16.3. Please download and install the update relevant to you from our downloads page: http://www.act.com/en-uk/support/downloads/emea Please try connecting with Google again afterwards and let us know how you get on.