Community
Showing results for 
Search instead for 
Do you mean 
Reply

Unable to share ACT 2009 database from Windows 7 server

Accepted Solution Solved
New Member
Posts: 10
Country: USA
Accepted Solution

Unable to share ACT 2009 database from Windows 7 server

[ Edited ]

Hello all. Here's the situation. I've been running an ACT 2009 database for the past several years over a Windows XP network, no problems. The database files ran out of the public documents folder (c:\documents and settings\All users\documents\ on the server) and all the client computers (five of them) had that folder mapped to drive letter F:.

 

Recently we started having hard drives come down with various failures, so we decided to upgrade the whole office to more recent hardware, Windows 7 computers. I've switched over some of the client comptuers already, no problem there. When I try to switch over the server, there's a problem. It runs fine if I open the company file locally on the server, but the client computers can't see it. I got a hint from an error message that said it couldn't see the database Supplemental Files.

 

So to review, in the public documents folder (c:\users\public\Public Documents in Windows 7, or simply F:\ as seen from the client computers) is the subfolder path ACT\ACT for Windows 11\Databases\, and in the Databases folder reside the three files Company.adf, Company.alf, and Company.pad. Also there is a folder called Company-database files, which is the "Supplemental Files" as far as I can determine. I notice on the Windows XP server, the Company-database files is shared, even though it is already within a shared folder. This is redundant, but seems important somehow.

 

Back over to the Windows 7 server, if I try to add a share to the Company-database files folder manually, Windows tells me I cannot share that folder. Within ACT, when I go into the Tools menu to Database Maintenance, the Share Database option is grayed out. And this is where I'm stuck. There should be no reason for this, the "Supplemental Files"/"Company-database files" folder is already fully accessible to the client computers, but I guess it is expecting it differently. How can I adjust either ACT or Windows to get this to work? I'm keeping the old Windows XP server online for now but this is not the ideal long term solution.


Accepted Solutions
Solution
Accepted by topic author Ray Kremer
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Unable to share ACT 2009 database from Windows 7 server

While I really like Windows 7, the move from XP to Windows 7, because of the added security, takes time to get used to and understand. Regarding sharing the ACT! database, having the database in a public folder allows other users to access the database however the sharing of the ACT! database is an internal function of the ACT! program and not Windows. This gets to the main change to administrator control in Windows 7. Even if you are a Windows administrator, most of the time you aren't running as an administrator because this is under control of the Windows User Access Control. To run a program for administrator function you need to right click on the icon to launch the program and choose the option to Run as Administrator. That will allow you to share the ACT! database.

 

I would also suggest you do a Google search for User Access Control, it will help you understand what's going on and option that you have.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129

View solution in original post


All Replies
Solution
Accepted by topic author Ray Kremer
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Unable to share ACT 2009 database from Windows 7 server

While I really like Windows 7, the move from XP to Windows 7, because of the added security, takes time to get used to and understand. Regarding sharing the ACT! database, having the database in a public folder allows other users to access the database however the sharing of the ACT! database is an internal function of the ACT! program and not Windows. This gets to the main change to administrator control in Windows 7. Even if you are a Windows administrator, most of the time you aren't running as an administrator because this is under control of the Windows User Access Control. To run a program for administrator function you need to right click on the icon to launch the program and choose the option to Run as Administrator. That will allow you to share the ACT! database.

 

I would also suggest you do a Google search for User Access Control, it will help you understand what's going on and option that you have.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 10
Country: USA

Re: Unable to share ACT 2009 database from Windows 7 server

Roy, I'll give that a try. I guess I mostly expected that since it was already a shared company file and I just copied everything straight across from one hard drive to the other, I wouldn't have to reconfigure that. And yes, the additional security stuff that Microsoft added with Win 7 is confusing at times.

New Member
Posts: 10
Country: USA

Re: Unable to share ACT 2009 database from Windows 7 server

Run ACT as Administrator, enabling the Share Database option, activate it, and Bob's your uncle. I wouldn't have thought that the Windows UAC would have that kind of reach into a rather older version of ACT, but it does.

 

Incidentally, the Company-database files folder is once again independently shared. Obviously that part is important somehow. Perhaps that's the UAC again that wouldn't let me set up that share manually.

 

Thank you Roy, problem solved, and hopefully folks with the same issue will find their way to this thread in the future.