Community
Showing results for 
Search instead for 
Do you mean 
Reply

Unable to connect to server databse

Accepted Solution Solved
Copper Contributor
Posts: 10
Country: United States
Accepted Solution

Unable to connect to server databse

We've just started to try and use ACT!. We purchased 3 copies a couple of years ago for a project that never got off of the ground. Now, we are trying it again. Sage tech support won't talk to us because the version is too old. Boss won't spring for more copies until he sees this version running.

Anyway, here is the error message:

"The databse PFM_2 could not be accessed. In order to access the database, check your network connection and verify that your database server is available."

 

Data points:

1. 3 pc's used on this LAN, all running WinXP. One is set up as the 'server'.

2. DB is accessable on the pc that is the 'server'.

3. Error message above is from either of the other two workstations when they try to access the 'server' db.

4. .PAD file copied from the 'server' to each of the workstations - can see the .pad file in the 'open' database dialog box.

5. I have read through the comments in this forum back to the beginning without seeing this issue.

6. I thought it might be a permissions issue, but I can create and edit a text file using notepad on the 'server' in the ACT! folder.

7. I have added the other workstations in the 'manage users' pull down under 'tools'. It does sy I have only one license and the status of the other users (not the one on the server) is 'Active - not logged on'.

8. I've been through the knowledgebase at Sage and have tried a number of things including turning off 'opportunistic locking'. No joy there, either.

9. I'vre read "Improtant Issues Concerning Sharing an ACT! Databse over a Network", "How to set up a multi-user Database", How to share an act! database on a local area network", etc.

 10. Passwords on the workstations and server are in sync.

 

Can someone out there give me an idea of what I've overlooked?

Thanks, Mike

 


Accepted Solutions
Solution
Accepted by topic author mike449
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 10
Country: United States

Re: Unable to connect to server databse

Graeme,

 

BINGO! You got it!

Problem was that the SQL ports were being blocked by the Windows firewall. Everything seems to be working now. I can access the db from 2 Windows XP workstations and from the server keyboard. Document 19420 held the key to figuring this out. Now to start playing with ACT! to see if we spring for ACT! 2010 for 5 users.

Thank you very much for taking the time to work this through. I really appreciate it!

 

Mike Rioux

Lynnfield MA USA

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Unable to connect to server database

Can you browse from one of the workstations to the pad file on the server and try to open the ACT! database there? Copying the pad file to the workstations isn't necessary.
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Contributor
Posts: 10
Country: United States

Re: Unable to connect to server database

Hi Roy and thanks for the reply. Yes, I've tried the .PAD file both ways. On the workstation pointing to the server, and from the workstation directly. Same error message. I really think it is some form or permissions problem, but having the ability to create and edit a file on the server from a workstation kind of goes against that idea.
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Unable to connect to server database

Mike,

Please see KB Article 19640 for a list of possible causes and solutions for the error you are receiving.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 10
Country: United States

Re: Unable to connect to server database

Greig,

Thanks for the pointer. I tried all of the suggestions with the following results:

1. Share Database Option Disabled. The option is set to share and has been.

2. Permissions for Folders of the Shared Database. I shared EVERYTHING on this XP system. 

3. Compatbility Mode is enabled. Compatability mode was not enabled.

4. Damaged .PAD file. Could not do this as I did not have a copy of ACTDIAG on the computer. Attempts to download it from Sage gave me the error that it did not support this version of ACT!

5. Different ACT! versions. All versions are 8.0.2.82

6. SQL Server Browser and SQL Server (ACT7) Service. Services dialog box does not show any SQL entries except SQLAgent$ACT7 and it is set for manual start. When I try to start it, I get a 'service has stopped' message. This may be the bigest clue yet. But remember, ACT! runs fine on the computer that the database is running on; none of the remote computers on the LAN can see that database or the ACTDemo DB.

7. Firewall or Anti-Virus Blocking. I removed the A/V a while back (then added it back as my paranoa kicked in) Smiley Happy  No difference with or without A/V.

8. Windows Server 2008: Windows Firewall Incorrectly Configured to allow access to SQL Server. This is a Windows XP system that ACT! is installed on.

9. Data Execution Prevention (DEP) Settings. N/A applies to Vista

10. Damaged Preferences File. Like I said, databse runs fine on the hosted PC.

11. Compressed Files. No compressed files on the server.

12. Damaged Database. DB works OK locally.

13. Multiple Shares created for the database. Checked and this looks ok.

14. Problem on the client machine resolving the name of the computer hosting the database. I don't think this is a problem as I can ping the DB machine with it's windows name and its IP address.

 

Any other clues?

Thanks for the help,

Mike

 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Unable to connect to server database

Item #6 would seem to be an issue. While a client machine does not necessarily have to have the ACT7 instance of SQL installed in order to access a database hosted on another machine, it does need to have other SQL components installed in order to communicate with the SQL instance on the host. I would manually remove and then reinstall SQL from this machine:

- From the Control Panel/Programs & Features, uninstall any apps that start with "Microsoft SQL Server" and uninstall ACT!

- In Windows Explorer, delete the Microsoft SQL Server directory under C:\Program Files

- Remove the registry keys listed in KB Article 22957 under the section "Removing ACT! Registry Keys" (about halfway down the article)

- Reinstall ACT! from your CD or download (this will install ACT! and SQL)

 

Note: Being that this is a Vista machine , do not disable the Windows Firewall as this blocks all traffic to the machine.

 

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Unable to connect to server database

Mike,

Before continuing, I need to verify some specific information, which I really should have asked for earlier:

 

- What version of ACT! are you trying to install?

- What operating system are you trying to install on?

- If XP, what version (Home, Pro) and what SP #?

- If Vista, what version (Home Basic/Pro, Business, Ultimate) and what SP#?

 

Please post this information before continuing with the process.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 10
Country: United States

Re: Unable to connect to server database

Thanks for the reply.

It is ACT! 2006

Server is XP Pro SP3

Client is XP Pro SP3

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Unable to connect to server database

OK. In that case, you will want to follow all the steps in KB Article 15285, reboot and then reinstall.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 10
Country: United States

Re: Unable to connect to server database

Sigh. Performed the KB procedure. Twice. Both times ACT! comes up and immediately shuts down.

Now what?

 

Mike