Community
Showing results for 
Search instead for 
Do you mean 
Reply

Unable to add new contact to existing company

New Member
Posts: 2
Country: United States

Unable to add new contact to existing company

This is my first post on this forum, I hope somebody can shed some light on the issue I am currently facing with ACT.

 We've been running 'ACT! by Sage 2008 (10.0) Version 10.0.0.237, Hotfix 1' in our office for about a year.

 

Recently we added a new tab and populated it with over a dozen fields. Two of the users have laptops with remote databases. They syncronized their remotes with the master to pick up the new tabs and fields. I'm unsure if that action is the cause of our issue, but since then we are unable to add new contacts to existing companies. When I add a new contact to an existing company and hit the forward arrow, I get an error message that states the contact does not exist.

 

In trouble-shooting I discovered:

 

1. After I checked for errors and re-indexed, when I add a new contact the to an existing company and hit refresh, the contact display bounces back to contact '1' and the new contact is no-existent.

1. I can make a new contact from blank 

2. create new database and import from old gives me my functionality back but without the new tab and fields

3.master database backup and restore rebuilds database with the same fault

 

I hope this trouble report is clear.

 

Thanks in advance.

Moderator
Posts: 4,395
Country: USA

Re: Unable to add new contact to existing company

If I understand correctly, the issue happens on the master database as well.  Does this happen with any company?  If you create a new company, do you get the same issue?

 

Creating an empty copy of the database it will retain the customized fields but you will have to transfer your customized layout.

 

How to Create an Empty Copy of Your ACT! Database

New Member
Posts: 2
Country: United States

Re: Unable to add new contact to existing company

David,

 

Thank-you for your response.

I tried your solutions. Each time I ended up with my contacts and tabs I had the same problem.

When I saved a empty version of my existing database I could create new contacts, but I could also create new contacts with my existing master database. I used the term company generically, to designate the company field.

 

When I lookup by company name, duplicate all fields, add new name, hit view refresh, thethe contact display reverts to #1 and the new contact is not registered.

I have made a new database and imported my masterdatabase into it. I can add contacts to that freely. 

 

Certain companies I can add new contacts to and others I can't. In the multiple database I've generated, the companies I can add contacts to and the ones I can't add to remain consistant and reproducible. Most examples I can't add to.

 

Our problem came up after our Act person generated new tabs and new fields and used syncronize from their remotes to pick up the new tabs and fields. Is it proper to use sync to pick up new tabs and fields or should a new remote be generated for those laptop users who use remotes after new tabs and fields are generated on the master?

 

My boss wants me to escalate this to a paid support request. Can you help?

Moderator
Posts: 4,395
Country: USA

Re: Unable to add new contact to existing company

If the issue is database specific, then it will need to go to database services for repair.  You can try running maintenance from actdiag to see if it will fix the issue.  On the empty copy, did the issue only start happening after you imported the contacts?

 

Customer Support: 866-903-0006

Customer Service:  877-386-8083

 

Database Rebuild and Repair Procedures