Community
Showing results for 
Search instead for 
Do you mean 
Reply

Sync not working - machine ping ok thru Hamachi - but Sync says 'ACT! is unable to connect to the Sync Server'

New Member
Posts: 1
Country: USA

Sync not working - machine ping ok thru Hamachi - but Sync says 'ACT! is unable to connect to the Sync Server'

I moved the publisher database to a new machine and fresh install of ACT2011.  ACT2011 is on the Subscriber and the database was created with ACT2011.

 

'Accept incoming Sync' is enabled on the publisher machine.

 

The main database location was reset on the Subscriber machine.

 

The ports are the same on both machines  65100

 

For some reason the 'subscriber' will not talk to the 'publisher'.

 

I rechecked to be sure both machines had the same database name.  From the ACT Menu ->  /help/about us/database information/database name

 

Also the Machine name is correct in the Subscriber for the publisher   And that is also the name in Hamachi

 

Any suggestions?

 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Sync not working - machine ping ok thru Hamachi - but Sync says 'ACT! is unable to connect to the Sync Server'

[ Edited ]

Hello jwm,

Welcome to the Sage ACT! Community. I believe with Hamachi you need to use the IP address of the VPN in the connection information, rather than the machine name. Please see KB Article 23333 to verify your setup.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 8
Country: USA

Re: Sync not working - machine ping ok thru Hamachi - but Sync says 'ACT! is unable to connect to the Sync Server'

Thank you for the response.

 

I did change both tne Connection information on the subscriber machine.      Synch Panel / Manage Synch Info   to the IP address, and changed the name under Manage Main Database Location  Synch Panal / Manage Main Database Location to the name of the publisher machine

 

Now I get different error messages

 

When trying to sync to the old publisher machine I get this message

 

'Failed to setup remote sync entity.  Invalid URI: The hostname could not be parsed'

 

When trying to sync to the new publisher machine I get this message

 

'ACT is unable to connect to the synch server.  Check to be sure 'Accept Incoming Sync' is enabled

 

I checked and it is enabled.

 

The Subscriber and New publisher both run Windows 7  32 bit

The old Publisher runs Win XP

 

This is becoming unacceptably challenging.

 

 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Sync not working - machine ping ok thru Hamachi - but Sync says 'ACT! is unable to connect to the Sync Server'

That first error indicates a problem with machine name or IP in the connection information. It may invalid or in an invalid format. Have you also tested the Hamachi connection. Both sides need to be fully connected (green). You can test by pinging the IP of the Hamachi network on the server from the remote to make it can connect.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 8
Country: USA

Re: Sync not working - machine ping ok thru Hamachi - but Sync says 'ACT! is unable to connect to the Sync Server'

Thanks for the reply,  Yes the two machines ping each other.

 

I gave up and gave Sage a call and paid for a support incident to get this cleaned up.

 

But thank you for your attention.   As I said this is becoming 'Unacceptably Challenging'  and a waste of my time.  Better to get the pro to handle it.  Took about an hour and a half....  But it appears to work  now between my laptop (subscriber) and my desktop (publisher).

 

The main issue was the new Publisher machine firewall was blocking Sage.  So had to set the firewall to allow Sage to get through.