Community
Showing results for 
Search instead for 
Do you mean 
Reply

Sync fails

New Member
Posts: 1
Country: United_Kingdom

Sync fails

[ Edited ]

Hi,

 

We have Act 2011 pro.

 

I have just moved the main database to anew machine. It is a windows 7 pro machine. The files are in a shared folder with everyone  full access.

 

When I try to sync the db from my laptop it all goes fine until the end. It goes through all the syncing steps ok until right at the end it gives the error:

 

Synchronization completion failed. Setuser failed because of one of the following reasons: the database principal 'dbo' does not exist, its corresponding server principal does not have server access, this type of database principal cannot be impersonated, or you do not have permission.

 

Does anyone have any ideas?

 

thanks,

 

Robert

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Sync fails

Hello Robert,

Welcome to the Sage ACT! Community. In regards to the sync error you are seeing, please see KB Article 25099 for suggested solutions.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Tuned Listener
Posts: 16
Country: United States

Re: Sync fails

Hi Greg, 

 

When I got to the point of changing the type of file, and trying to open my database, I got an error message that reads

 

"You don't have permission to open this file.

Contact the file owner or an administrator to obtain permission."

 

...and when I click OK, that message goes away - but it doesn't allow me to open the database.ADF.

 

And I am the only user, I am the file owner, and the administrator.

 

Any ideas?

Thanks!

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Sync fails

When opening the ADF you will need to run ACT! using the 'Run as administrator' option. To do this: close ACT! > right-click ACT! icon > select 'Run as administrator'.
Greg Martin
Sage