Community
Showing results for 
Search instead for 
Do you mean 
Reply

Sorting by Date in the "List View" Doesn't Work Properly

New Member
Posts: 2
Country: USA

Sorting by Date in the "List View" Doesn't Work Properly

Hi Everyone,

 

I'm running ACT version 2010 Version 12.0.409.0, Hotfix 3.  I have a "date" field in which I have contract end dates.  I enter the information in the standard MM/DD/YEAR format.  When I sort by this field in my "list view," it doesn't sort by year first.  It sorts by month, then day, then year. 

 

I have figured out that when you export the list to Excel, Excel recognizes that the data is a date and sorts by year/month/day (even though it displays as month/day/year).  Why isn't ACT capable of doing this?

 

I have tried to see if there is an option I am missing when I create a new field that is in the "date" format, but don't see an option on how to specify how to sort the date.

 

Anyone figure this out yet?  It's too hard to read the format that would make the field sort properly (2012/12/31).  Is it fixed in a newer version?

 

Thanks for your help!

-Mark

Platinum Elite Contributor
Posts: 6,651
Country: USA

Re: Sorting by Date in the "List View" Doesn't Work Properly

The data type for the field is character so you get a character sort. You need to change the field data type to date and then it will sort as dates.. You can check your field in the layout, if the dropdown shows a calendar then it's a date field.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129