Community
Showing results for 
Search instead for 
Do you mean 
Reply

Some Advice

New Member
Posts: 3
Country: United States

Some Advice

We have some issues, and I was hoping someone could give some advice.

 

We have Act! for Workgroups 2007 working on 3 Windows XP machines, and 1 Windows Vista machine. They all sync fine with each other. 1 of the XP systems went down, so the user is now on his Mac. He got VMware Fusion to Run Windows emulation. We installed Act! on there, got the database loaded and everything went fine, until the sync. 

 

I cannot get it to sync with the main database. I get a message saying that I need to check to see if Incoming Syncs is on, which it is. 

 

I am not sure if it is an Act! issue, or a VMware issue, but I need to get it resolved.

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Some Advice

BTW 2007 Premium isn't really supported on Vista

 

Questions:
1. Are you sure that the version/build of ACT! is the same (check Help | About)? All versions syncing to the same database must be the same build.


2. What method of sync - Application (they have ACT! open on a machine at their end), Network (via a specific port - find the port number), Internet (via IIS at their end). Network is most common. So, lets assume that for now...

3. Assuming Network, find the port of the sync server (default is 65100) - in ACT!: Click the Tools menu, and then click Synchronization Panel. The Synchronization - Select a Synchronization Task dialog box appears. Under the User Tasks section, click Manage Connection Information. The Synchronization - Sync Server Connection dialog box appears. Make sure Machine Name and Port are the same on both systems.

 

4. Have you tried turning off the Windows firewall? Are both on the same operating system and build (XPsp2 added some firewall changes)

 

5. Can you ping the machinename host? Try from both machines and see if the IP it resolves to is the same.


6. Check network connectivity. Open a command prompt and: "Telnet MachineName Port" (no quotes, type telnet and then the MachineName and Port (with spaces between each). Press enter.
Is there a difference between the failing and a good machines in their response?

My first guess would be that WINS isn't properly replicating... ping machinename from the working machine, get the IP address and try "Telnet IPaddr 65100" on the failing one. If that didn't work in 6 but works this way, try changing the machinename in the sync panel to the IP address.

New Member
Posts: 3
Country: United States

Re: Some Advice

Yeah, they told me it wasnt really supported in Vista. Vista hasn't been the issue.

 

The issue currently is getting the Mac machine, running VMware Fusion with Windows XP emulation to sync. The versions of Act are the same and updated across the board. I used the exact same installer for all of them. My database is on the Mac, and it is opening fine. I just can't get it to sync. I have turned off all firewalls to make sure, and the port is set correctly. Both the XP machine, and the Mac running XP emulation have SP3 installed. 

 

Also, just an fyi, I am also running Hamachi VPN on all machines. 1 Machine is on East coast, and others are on West. All need to be able to sync with My computer. The only one that can't right now is the Mac running VMware Fusion. 

New Member
Posts: 3
Country: United States

Re: Some Advice

BTW, Thanks for your help Smiley Happy
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Some Advice


mcole2100v wrote:

 

Also, just an fyi, I am also running Hamachi VPN on all machines. 1 Machine is on East coast, and others are on West. All need to be able to sync with My computer. The only one that can't right now is the Mac running VMware Fusion. 


Then, my guess is WINS/DNS isn't being properly propagated - it's common with VPNs

 

If so, changing the machinename to the IP would fix it.