Community
Showing results for 
Search instead for 
Do you mean 
Reply

Smart Tasks won't start

Accepted Solution Solved
New Member
Posts: 5
Country: USA
Accepted Solution

Smart Tasks won't start

Downloaded & installed 2011 pro. with no errors.  Converted & opened several existing database(s), no problems reported, everything seems to be there.

 

Click on schedule smart task - I get nothing - no errors - no popups - nothing

View Status of Smart Tasks - nothing

Show Pending Smart Tasks step(s) - window opens but it's empty (not a complete surprise).  Says I have 0 pending

When I click on View Status of Smart Tasks link in this window however... that's were it gets interesting.  I get a window that has about 7 lines completely filled with errors.

 

Starts off with

Resolution of the dependency failed, type=Act.UI,Workflow.Dialogs.ManageWorkflowsDialog",name="", Exception message is: The current build operation (buildkey Build Key[Act.UI.Workflow.Dialogs.ManageWorkflowsDialog,null]) failed:'../ViewsDefinitionView.xaml' value cannot be assigned to property 'Source of object .... and on and on

 

basically - I would say that the installation failed to either install everything or complete properly.  I did not however receive any install errors.

 

I've already gone the route of disconnecting all the database(s) - uninstalling act 2011 via the install proceedure which I simply re-ran, rebooted - reinstalled and just to be safe - before opening any of my existing databases, I simply created a new fresh database.  Again selecting smart tasks - nothing, selected  view status - nothing and then show pending and clicked the link to View Status I got the exact same error result.

 

I tried opening the infamous 2011demo database with the same result(s) as well.

 

Anyone go any ideas on where to go with this?

 

I suppose I will try installation support on monday but I thought I would see if anyone has any ideas I could try in the meantime.

 

  

 

 


Accepted Solutions
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
New Member
Posts: 5
Country: USA

Re: Smart Tasks won't start

Problem resolved.

 

Since there seemed to be no other explaination as to why the manage smart tasks was not "starting" it was believed to be some sort of a faulty installation although no installation errors were reported either on the screen on in the application event log during the initial install.

 

We undertook the following steps.

 

1. Went to add/remove programs and ran a repair (update) on MS .net 3.5 sp1

2. Ran a detect & repair on MS Office 2007

3. The tech downloaded and installed a sage  "uninstall.exe" application and ran that.  Don't know if re-running the install with the remove option would have worked as well.

4. Ran a fresh install of the act 2011

 

Problem resolved.  Smart tasks now starts.

View solution in original post


All Replies
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Smart Tasks won't start

Hello Siliconcty,

If your computer is running either Vista or Windows7, try running Act! 'as administrator'.  To do this: close Act! > right click on Act! icon > select 'Run As Administrator'.

 

If that does not resolve the issue, try recreating your Act! Preference files.  Instructions for this can be found at this link: KB Article 14770.  I recommend using the 'Alternate Method: Manually Rebuilding Preferences' steps.

 

Greg Martin
Sage
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
New Member
Posts: 5
Country: USA

Re: Smart Tasks won't start

Problem resolved.

 

Since there seemed to be no other explaination as to why the manage smart tasks was not "starting" it was believed to be some sort of a faulty installation although no installation errors were reported either on the screen on in the application event log during the initial install.

 

We undertook the following steps.

 

1. Went to add/remove programs and ran a repair (update) on MS .net 3.5 sp1

2. Ran a detect & repair on MS Office 2007

3. The tech downloaded and installed a sage  "uninstall.exe" application and ran that.  Don't know if re-running the install with the remove option would have worked as well.

4. Ran a fresh install of the act 2011

 

Problem resolved.  Smart tasks now starts.