Community
Showing results for 
Search instead for 
Do you mean 
Reply

Smart Tasks Run Manually, But Not Automatically

Accepted Solution Solved
Copper Contributor
Posts: 75
Country: USA
Accepted Solution

Smart Tasks Run Manually, But Not Automatically

[ Edited ]

Not sure why I can't get Smart Tasks to run automatically.  Auto Run is enabled.  Trigger is set to a specified time. Run only once for any record is unchecked.  I am logged in to ACT.  The criteria produces records everytime I run the Smart Task manually so I know there are records.  I am running ACT as administrator.

 

I noticed that the Sage ACT! Scheduler service does not start.  When I try to start it I receive an info dialog box stating " the Sage ACT! Scheduler service on Local Computer started and then stopped.  Some services stop automatically if they are not in use by other services or programs"

 

Read another post that said to reinstall ACT!  I did that and it didn't solve this problem.


Accepted Solutions
Solution
Accepted by topic author alexlimbert
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Smart Tasks Run Manually, But Not Automatically

Ok. Always good to rule that out first.

The next thing is: try disabling and then re-enabling the automated run. When a scheduled smart task is updated, it has to be disabled/re-enabled for the schedule to take effect.

Also, you'll want to test running a scheduled smart task in another database (ACT! demo or a new database).

And - ensure that all Important Windows updates have been applied, especially those concerning the .Net program.
Greg Martin
Sage

View solution in original post


All Replies
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Smart Tasks Run Manually, But Not Automatically

The ACT! Scheduler isn't involved with the running of Smart Tasks, so that isn't the issue.

A possible cause:
Scheduled Smart Tasks will only run if the database is open at the scheduled time. For example: if you have the tasks scheduled to run after-hours and the database is closed, they will not run.

Greg Martin
Sage
Copper Contributor
Posts: 75
Country: USA

Re: Smart Tasks Run Manually, But Not Automatically

Thank you Greg.  ACT! was running the whole time.  I must have tested it 10 times with ACT! running already.

Solution
Accepted by topic author alexlimbert
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Smart Tasks Run Manually, But Not Automatically

Ok. Always good to rule that out first.

The next thing is: try disabling and then re-enabling the automated run. When a scheduled smart task is updated, it has to be disabled/re-enabled for the schedule to take effect.

Also, you'll want to test running a scheduled smart task in another database (ACT! demo or a new database).

And - ensure that all Important Windows updates have been applied, especially those concerning the .Net program.
Greg Martin
Sage
Copper Contributor
Posts: 75
Country: USA

Re: Smart Tasks Run Manually, But Not Automatically

RIght on!  I disabled my SmartTasks, then changed them, then reenabled and that fixed my problem.  I think I recall reading that that was required in the help file but I must have forgotten.  Thank you very much Greg!