Community
Showing results for 
Search instead for 
Do you mean 
Reply

Should SQL Server Agent (ACT 7) be disabled???

Astute Commentator
Posts: 67
Country: United States

Should SQL Server Agent (ACT 7) be disabled???

Should SQL Server Agent (ACT 7) be disabled?

I get an error every time I start up all of a sudden: Sage Act was unable to start SQL Server Instance and open the local database.

When I go into services:  SQL Server Agent (ACT 7) says disabled.

SQL Server (ACT 7) says automatic. I have to start it manually though - to get ACT to work. It is also set to Local System under the "log on" tab.

SQL Server Browser says Started, Automatic.

ACT 2012

Windows 7 professional 64 bit.

It's only one version of ACT on 1 computer only.

Thank you!

 


Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Should SQL Server Agent (ACT 7) be disabled???

SQL Server (ACT7) definitely needs to be started. It is required to open the database. If it is not starting up automatically after rebooting the computer, go into Services > right click on the service > select Properties > change the Startup Type to "Automatic Delayed". There may be too much going on at boot up...
Greg Martin
Sage
Astute Commentator
Posts: 67
Country: United States

Re: Should SQL Server Agent (ACT 7) be disabled???

But Should SQL Server Agent (ACT 7) be disabled?

I know that SQL Server (ACT 7) should be on, because I have to start it manually each time, but should Should SQL Server Agent (ACT 7) be disabled?That it how it is set right now.

Thank you!

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Should SQL Server Agent (ACT 7) be disabled???

It should not be set to 'disabled'. Set it to 'Automatic' or 'Automatic - delayed'.
Greg Martin
Sage
New Member
Posts: 1
Country: Australia

Re: Should SQL Server Agent (ACT 7) be disabled???

I too have recently received an error message on ACT start up: Sage Act was unable to start SQL Server Instance and open the local database.

"SQL Server (ACT 7)" was not running and set to Automatic.

I tried 'Automatoc - delayed' with no outcome unfortunately.

What I tried next may be helpful:

Open the "SQL Server (ACT 7)" service > go to Recovery tab.

For the First Failure select "Restart the Service".

Likewise with the Second Failure.

(Subsequent Failures to remain as is "Take No Action")

Startup Type used: Automatic

Running on ACT 2012

Windows 7 professional 64 bit.