Community
Showing results for 
Search instead for 
Do you mean 
Reply

Set WshShell = CreateObject("WScript.Shell")

New Member
Posts: 19
Country: USA

Set WshShell = CreateObject("WScript.Shell")

I am running Sage ACT!Premium 2011 Version 13.1.111.0. Hotfix 1 on a Windows 7 64 bit machine and it runs fine but for some reason lately every time I boot the computer I get Start ACT7 - Notepad box on the destop with the following message in it.........    Set WshShell = CreateObject("WScript.Shell") WshShell.Run chr(34) & "C:\StartACT7.bat" & Chr(34), 0

 

I exit the box and ACT runs fine and synchs with the remote database etc fine as well.  This pop up has been a recent occurrance so it is not something I have seen before.  Does anyone know how to turn it off or what it is referencing if it is signalling something is wrong?

 

Any suggestions will be greatly appreciated.

 

Thanks,

 

Bob 63

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Set WshShell = CreateObject("WScript.Shell")

The name 'StartACT7.bat' would infer that it is attempting to start the MS SQL ACT7 instance, which is apparently starting correctly since you are able to open the database.

It appears the actual bat file is located on the C: drive.

Do you happen to have any items listed under Start > All Programs > Startup with the name 'StartACT7.bat'? If yes, drag it out of Startup (to desktop) and test rebooting.
Greg Martin
Sage
New Member
Posts: 19
Country: USA

Re: Set WshShell = CreateObject("WScript.Shell")

Thank you. 

 

I looked on the C drive for a Start.All Programs > Startup as you noted but did not find any folder under C with that name.  Maybe I am lookig in the wrong place? 

 

So, I went into the MSCONFIG Startup and found Start Act 7 in the start up ms config folder checked so unchecked it and rebooted.  No Set WshShell message on reboot however MSSQL$ACT7 is not running and has to be started manually. 

 

I am running windows 7 and have loaded both Act and Outlook in 32 bit mode and they were working fine but for this original error message. 

 

I will recheck the MSCONFIG box that I unchecked since it appears that gets in the way of MSSQL$ACT7.   

 

There is a StartACT& file on the C drive that I located not in a folder just on the drive.  I left it as is.

 

Thanks for any further help you might be able to suggest.

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Set WshShell = CreateObject("WScript.Shell")

Definitely put the Msconfig settings back to the original state...

 

I was actually refering to the Windows Start button > Programs > Startup folder - is there a command in there for StartACT7?  If there is, drag it out to the desktop.  It can be dragged back in if needed.  Reboot to test.

 

The file you found on the C: drive is most likely the file having the error, I expect that something listed in the Startup folder is initiating it.  Right click on the file and select Open With > select Notepad.  If it contains commands to start SQL ACT7, rename that file (add '.old' to the end), then reboot to test.

Greg Martin
Sage
New Member
Posts: 19
Country: USA

Re: Set WshShell = CreateObject("WScript.Shell")

Sep 6, 2012 1_27_06 PM.jpg

I removed the StarACT7 file from the startup menu and that seems to have done the trick since the notepad did not appear on boot up.

 

However, I am still getting intermittent startups where the MSSQL$ACT7 does not start at start up so I have to start it manually. If i let the computer sit a bit after boot up it will sometimes start. No matter what setting I put it on it still seems to sometimes not start right away. Maybe this has something to do with the C drive file I found?

 

I did a screen print of the file on the C drive since I cannot change the extension...none appears.

 

This intermittent non star up of the MSSQL$ACT7 service would be nice to resolve also if we can.

 

Many thanks for staying with me on this.

 

With kindest regards and a thank you,


Bob

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Set WshShell = CreateObject("WScript.Shell")

I'm not sure what it doesn't like about the file, but since the real issue is the service not starting correctly to begin with...

There may be a resource conflict when the computer is booting up, causing the intermittent failure with SQL Server (ACT7).

Set SQL Server (ACT7) to 'automatic - delayed':
Go into Services > right click 'SQL Server (ACT7)' > select Properties. Change Startup Type to Automatic (Delayed).

This pushes the start command to later in the boot process, hopefully this will allow the service to start automatically more frequently (or all the time).
Greg Martin
Sage
New Member
Posts: 19
Country: USA

Re: Set WshShell = CreateObject("WScript.Shell")

Thanks Greg.  I will give it a try.  At this point I have it set to Automatic and to keep trying on each failure.  I will see if delayed helps it may well be the case.  I find Adobe messes things up often and have a lot of Adobe software on the sytem both for video editing and photo editing as well as PDF generation and editing so could be something there.  But, it is working and if I give it enough boot time it generally does start so I will set it to delayed and see if that helps.  I have left the file pulled out of the start up and it seems to be working fine now.

 

Thanks for staying with me on this.

 

Bob