Community
Showing results for 
Search instead for 
Do you mean 
Reply

Scheduler must run as administrator Act 2011 Windows 7 (64)

Accepted Solution Solved
Copper Contributor
Posts: 60
Country: Canada
Accepted Solution

Scheduler must run as administrator Act 2011 Windows 7 (64)

I have found that for the Act Scheduler to function on my system I must run it as administrator.  Otherwise the scheduler will not run the activities, cannot truncate its log file (cannot write to the log file, etc).  I have tried removing the various XML file (schedule, log ) and letting it recreate them (which it does), but it still cannot then run the scheduled activities.

 

As the scheduler is auto started (i.e. not from the startup folder), I'm not sure where I would set it to always start as administrator.  I never had to do this under Act 2010.  Right now, after every reboot, I need to exit the scheduler and manually restart it (with "run as administrator").  If I forget to do this, I (of course) stop getting backup files.

 

Any idea why this is happening?

===========================
Ken Wiens
Project and Program Manager
www.kgw-consultants.com
============================

Accepted Solutions
Solution
Accepted by topic author kenwiens
‎09-25-2015 03:20 AM
Copper Super Contributor
Posts: 78
Country: Australia

Re: Scheduler must run as administrator Act 2011 Windows 7 (64)

Hi Ken,

I suggest going to the C:\programData\ACT\ACT Data\ directory,
rightclicking ACT Data, and setting permissions to Full Control Everyone.

That has resolved the issue for most clients. If you still get the error message, set the permission to Full Control Everyone on each individual file in that directory.

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Scheduler must run as administrator Act 2011 Windows 7 (64)

Copper Contributor
Posts: 60
Country: Canada

Re: Scheduler must run as administrator Act 2011 Windows 7 (64)

If I did this, it would then run under the "administrator" account as opposed to my personal / local account (which is also an administrator).  When you run a service under a different account, I believe you lose the ability for that service to interact with the desktop.  Wouldn't that mean that I could no longer add and remove tasks, view the log etc?

 

I was hoping that I didn't need to run the scheduler as a service.  Does everyone need to set this service to run under the windows "administator" account  or am I missing something here?

 

Thanks,

Ken

 

===========================
Ken Wiens
Project and Program Manager
www.kgw-consultants.com
============================
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Scheduler must run as administrator Act 2011 Windows 7 (64)

Normally you only need to set it if the database is on another machine, or you you are backing up to another machine

What error is it giving in the logs?

What are you scheduling?
Copper Contributor
Posts: 60
Country: Canada

Re: Scheduler must run as administrator Act 2011 Windows 7 (64)

The database in on the same machine as Act client  (my desktop)

 

I don't get any errors in the logs because the scheduler can't open the log file (just create it - isn't that a bit odd!)

 

I have no trouble opening and editing the log file directly though (using the same account as the scheduler is using)

 

A typical error if I ask the scheduler to purge the log is:

 

Failed to purge scheduler log.  Error occurred while saving scheduler log file.  Access to the path 'C:\programData\ACT\ACT Data\SCHEDULER_LOG.xml' is denied.

 

I can delete the log file and let the scheduler re-create it - but I still get the same errors.

 

I am scheduling both maintenance and backups.

 

Thanks,

Ken

 

===========================
Ken Wiens
Project and Program Manager
www.kgw-consultants.com
============================
Solution
Accepted by topic author kenwiens
‎09-25-2015 03:20 AM
Copper Super Contributor
Posts: 78
Country: Australia

Re: Scheduler must run as administrator Act 2011 Windows 7 (64)

Hi Ken,

I suggest going to the C:\programData\ACT\ACT Data\ directory,
rightclicking ACT Data, and setting permissions to Full Control Everyone.

That has resolved the issue for most clients. If you still get the error message, set the permission to Full Control Everyone on each individual file in that directory.
Copper Contributor
Posts: 60
Country: Canada

Re: Scheduler must run as administrator Act 2011 Windows 7 (64)

Thankyou!! That works.
===========================
Ken Wiens
Project and Program Manager
www.kgw-consultants.com
============================