Community
Showing results for 
Search instead for 
Do you mean 
Reply

Scheduler Errors

Accepted Solution Solved
Copper Contributor
Posts: 54
Country: United States
Accepted Solution

Scheduler Errors

Hi,

 

I'm trying to make some changes to Act Scheduler but when I try to add a database to backup, run maintenence on, etc. or to delete a database from Scheduler that I no longer use, it gives the error : Error occurred while saving server config file. Access to the path 'C:\program data\act\act data\scheduler_file.xml' is denied. at System.IO._Error.WinIOError...and a bunch of other stuff. If you want the entire mess I can email a screen shot.

 

Anyone have any experience with this type of error?

 

Thanks,

 

Dan


Accepted Solutions
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
Copper Super Contributor
Posts: 78
Country: Australia

Re: Scheduler Errors

Dan,

 

It sounds like you have two problems. You should first go to C:\program data\act\act data\. Then rightclick on the act data folder,

Select properties, click on the security tab, and set the permissions to Full Control Everyone.  That will fix one error message.

 

To fix the others, you will have to try these two KB's:

 

Deleting the scheduler file

 

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2392...

 

And then setting the scheduler to run as an administrator account

 

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=1831...

 

Steps 1 & 2 might fix the problem, so test after each step. Good luck, this should get you 9/10's of the way toward a solution.

View solution in original post


All Replies
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Scheduler Errors

Dan,

What is the operating system for your computer?  And what version of ACT! are you running?

 

If this is a Vista or Windows 7 OS, try: close Act! and Scheduler completely > launch Act! 'as admin' (right click on Act! icon > select 'Run As Administrator') > go to Tools and select Act! Scheduler > attempt to update.

Greg Martin
Sage
New Member
Posts: 3
Country: USA

Re: Scheduler Errors

I successfully scheduled a backup of one database a month ago and it works. But now for some unknown reason, I am getting the exact same message for any ACT database I try to setup on Scheduler. I have Win7, ACT Premium 2011 and share my databases but do not sync them.
Copper Contributor
Posts: 54
Country: United States

Re: Scheduler Errors

Hi Greg,

 

I'm using Windows 7 Home Premium and Act 2011 with the latest upgrades. Signing in as Admin doesn't change anything.

 

I'm still getting the errors so not getting any backups or database maintenence. I have a windows home server that gives me the backups but hae to do database manually.

 

Also, I can't get my database to sync with outlooks, either the contacts or the calendar.

 

Any ideas?

 

Thanks,

 

Dan

Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
Copper Super Contributor
Posts: 78
Country: Australia

Re: Scheduler Errors

Dan,

 

It sounds like you have two problems. You should first go to C:\program data\act\act data\. Then rightclick on the act data folder,

Select properties, click on the security tab, and set the permissions to Full Control Everyone.  That will fix one error message.

 

To fix the others, you will have to try these two KB's:

 

Deleting the scheduler file

 

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2392...

 

And then setting the scheduler to run as an administrator account

 

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=1831...

 

Steps 1 & 2 might fix the problem, so test after each step. Good luck, this should get you 9/10's of the way toward a solution.

Copper Contributor
Posts: 54
Country: United States

Re: Scheduler Errors

Ok, that did seem to fix that error - very much appreciate the help. Now on to work on getting ACT to sync my contacts with Outlook.... (always something...)

 

Thanks again,

 

Dan

Copper Super Contributor
Posts: 78
Country: Australia

Re: Scheduler Errors

No worries Dan. Glad that's all it took.
Copper Super Contributor
Posts: 21
Country: United States

Re: Scheduler Errors

I'm running W7x64 Ultimate & Act 2010 V12.1.181.0 Hot Fix 5 which runs as administrator. I recently changed the name of my database and scheduler ceased functioning although it had run without issue prior to that. I've tried stopping & restarting the service, resetting it as an administrator service, deleting the scheduler xml file & rebuilding it by recreating the service. There are no entries in the log. It doesn't even appear to be trying to start the backup. I've triple checked for typos and obvious errors. I run 3 drives & backup to the E: drive which is local and used for all data. ACT program is located on the D: drive. Manual backup works just fine. It wouldn't bother me except my backup program won't copy the Act database due to the sql server blocking it and I refuse to have unbacked up data. What next???