Community
Showing results for 
Search instead for 
Do you mean 
Reply

SQL Server ---- Eating Up Memory

Tuned Listener
Posts: 19
Country: USA

SQL Server ---- Eating Up Memory

How to I reduce the size of or set limits on how much memory the SQL Server can use. 

My computer is DELL Latitude D630  2000MHz 2048MB  120GB  (WIN XPP+) 14.1 DVDRW 10/100/1000 NIC  56 kbps  8 MB VRAM.

 

Please provide a solution to this problem if you have one.

 

Thanks

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: SQL Server ---- Eating Up Memory

Tuned Listener
Posts: 19
Country: USA

Re: SQL Server ---- Eating Up Memory

What should the settings be as for minimum and maximums?

 

Thanks

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: SQL Server ---- Eating Up Memory

When you say it's eating up memory... how much is it using?
After how long?
How many contacts?
Maybe try a Max of 1024 or 768 and see how it helps?

You might also try:
Tools | Release ACT! Memory
And set to 60 minutes
Tuned Listener
Posts: 19
Country: USA

Re: SQL Server ---- Eating Up Memory

The SQL Server has gone as high as 1 gig at times.  I have 2500 contacts.  I will try your recommendation. 

 

Thanks

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: SQL Server ---- Eating Up Memory

1GB would be the max, depending on the version of SQL

If the RAM usage is an issue, you might try setting 512 and see if it gets to slow or not
Tuned Listener
Posts: 19
Country: USA

Re: SQL Server ---- Eating Up Memory

Thanks so much for your help.
Have a nice day!
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: SQL Server ---- Eating Up Memory

New Member
Posts: 1
Country: USA

Re: SQL Server ---- Eating Up Memory

Maybe you can help me. I have a similar issue.

I'm running Microsoft Small Business Server 2011 Standard Edition with 32 GB RAM.

I've set ACTDIAG Server memory to minimum 1024MB and Maximum 2048MB and I've set the release to 30 minutes.

After a day or two SQL server uses ALL avaialble memory in the server. It reaches 14GB after 2 days when we use ACT!.

I've verified in SQL Management Studio that the maximum is set to 2048MB.

If I disable the ACT! instance then SQL never allocates more than 4096MB

Why does it continue to eat up ALL memory? It causes the server to run extremely slow.

Please help.

Thank you,

Devin