Community
Showing results for 
Search instead for 
Do you mean 
Reply

SQL Server ACT7 Must Be Restarted

Copper Elite Contributor
Posts: 124
Country: USA

SQL Server ACT7 Must Be Restarted

ACT 2009 on WinXP SP3

 

I have several ACT databases created in ACT 2009.  The databases are located on a TrueCrypt volume which is mounted before running ACT.  ACT itself is on the local C: drive.

 

Now here's the interesting part:

I'll load everything up and ACT won't be able to find one particular database.  I run ACTDIAG and all of the databases are listed but the one in question has a status of "RECOVERY_PENDING".  In order to load the database I must run Services.msc and restart the ACT7 instance of SQL Server.

 

I just noticed that the troubled db is the one most recently created.  

 

Strange...all of the other databases which are located on the same TrueCrypt volume do not experience this issue.  I'm going to create a new db to see if it's some kind of stack issue with SQL Server but thought I'd get this logged here for additional ideas.

Copper Elite Contributor
Posts: 124
Country: USA

Re: SQL Server ACT7 Must Be Restarted

Update:

I created a new db named "GH_Last_Created" within ACT 2009 to the mounted TrueCrypt volume.  I then shut everything down and rebooted. 

Upon reboot I mounted the TrueCrypt volume and ran ACTDIAG.  All of the databases have a status of ONLINE (including the database mentioned in the message above) except for GH_Last_Created which has a status of RECOVERY_PENDING. 

 

Any ideas on what is going on here?

Bronze Contributor
Posts: 955
Country: Australia

Re: SQL Server ACT7 Must Be Restarted

Have you tried to detach the last created database from within ACTdiag and then open the .adf file for that database to reattach it to the SQL instance

 

It sounds like the instance is not releasing the last created database once it is created and this action might force this to happen.

Paul Buchtmann
pbuchtmann@ozemail.com.au Australia
Australia's First ACT Consultant (1989)

FREE Record History to change default to Call or To-Do for ACT! 2010-2012 versions. Custom versions also available.
Copper Elite Contributor
Posts: 124
Country: USA

Re: SQL Server ACT7 Must Be Restarted

[ Edited ]
Paul,

Thanks for the reply.

1. Upon reboot and mounting the volume my last db, "GH_Last_Created", is RECOVERY_PENDING and the Detach Database option is grayed-out.  

2. I restarted the ACT7 instance from within the Services snap-in.

3. I detached GH_Last_Created from within ACTDIAG.

4  I launch GH_Last_Created.adf from Windows Explorer.  ACT verifies and opens the database.

5. Next, I'll close everything and reboot.  Then I'll check to see whether GH_Last_Created can reattach itself...

 

---***---

Back after reboot.

6. ACTDIAG indicates status for GH_Last_Created is RECOVERY_PENDING.  

 

Rats.

 

Message Edited by GregH on 11-25-2008 11:49 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: SQL Server ACT7 Must Be Restarted

Try this:

In ActDiag, go to Server/Server Settings...go to the Database Warmup tab. Make sure "Enable Automatic Database Warming" is checked, then for "Warm up the ### most recently...", put in the number of databases you currently have.  Click Apply, close ActDiag, then restart the ACT7 SQL Server from your services list.  Then follow the normal process you described earlier and see if the database still comes up as recovering.

 

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Elite Contributor
Posts: 124
Country: USA

Re: SQL Server ACT7 Must Be Restarted

Greg,

I followed your instructions but it did not work.  I thought maybe it has to do with the large number of customized fields, therefore, I used the Demo database and made a local copy on my C Drive and another copy (Test_On_TrueCrypt) on the encrypted volume.

I opened each database from inside ACT.  So far, so good.

I rebooted and remounted the encrypted volume.  I ran ACT and could not open Test_On_TrueCrypt on the encrypted volume.  I ran ACTDIAG and my databases are listed and as expected, Test_On_TrueCrypt was not ready.

The thought occured to me that Test_On_TrueCrypt was the last db on the encrypted volume which I accessed.  So I opened another db on the encrypted drive, GH_Traveler, and then closed ACT.

I rebooted and attempted to open GH_Traveler - no go.  I checked ACTDIAG and now Test_On_TrueCrypt was online but GH_Traveler was not.

It appears that the last accessed db on the encrypted volume is not "warming up."

Greg
New Member
Posts: 2
Country: United States

Re: SQL Server ACT7 Must Be Restarted

Greg, Greig, and Paul:

 

I, too, have a RECOVERY_PENDING problem but the impacted databases are ACT10Demo and ActEmailMessageStore ... both show a DB size of 0.0.  No amount of massaging or manipulation has fixed this problem for me.  I am running ACT! 2008 for Real Estate on Windows XP sp2.  Any suggestions?

 

Constance

 

Copper Elite Contributor
Posts: 124
Country: USA

Re: SQL Server ACT7 Must Be Restarted

[ Edited ]

Constance,

Have you run Services.msc and restarted the ACT7 instance of SQL Server?  What is the db size when reported by ACTDIAG after that?

What does Windows Explorer show for file size of the databases?  If the file size is 0 then they probably didn't install successfully. 

 

My issue has not been resolved so I simply restart SQL Server each time I prepare to load ACT.  --Sigh--

Message Edited by GregH on 01-11-2009 10:15 AM
Copper Super Contributor
Posts: 54
Country: Canada

Re: SQL Server ACT7 Must Be Restarted

For a simple workaround, those having this problem when using TruCrypt can try the following:

 

Create a batchfile with the following command lines in it:

 

NET STOP MSSQL$ACT7

NET START MSSQL$ACT7

 

You can either place this file in your StartUp directory in Windows, or just simply run it prior to opening your Act database (or opening Outlook if your Act addressbook is attached to it)

Michael Kadlec
Act! Certified Consultant
Corelogix Corporation
Copper Elite Contributor
Posts: 124
Country: USA

Re: SQL Server ACT7 Must Be Restarted

Michael,

Thanks for the workaround.  I'd looked all over (well, as best as I could) to find something to that effect. I'll create the batch and run it. 

Thanks for helping stamp out needless keystrokes! 

 

Greg