Community
Showing results for 
Search instead for 
Do you mean 
Reply

*SOLVED* ACT 2011 hanging during search/lookup

New Member
Posts: 2
Country: USA

*SOLVED* ACT 2011 hanging during search/lookup

[ Edited ]

Hi,

I'm running ACT 2011 across a LAN of 5 workstations (one of which also hosts the database). I'm having issues with the program hanging sometimes during lookups. The program says it's Not Responding for 10-30 seconds at a time. Everything will work fine for an hour or so in the morning, then starts hanging on almost every lookup. After a few hours it starts hanging for longer (just now it took almost 2 minutes). When this happens I'm also getting errors when trying to create or reschedule activities or add notes, saying the contact doesn't exist.

 

A little background, I had ACT up and running pretty well (after configuring Windows firewall to open various ports) then had to switch routers. Since then I've been having issues. I had to reopen ports to initially get it working. A day or two after getting it initially reconnected I started having problems connecting with all but the local machine.

Manually starting the ACT7 SQL Agent seemed to work for a day or two then stopped working (it was set to AUTO but was never listed as started). Every time I manually started the service it gave me a message that it started then stopped. I had read I may need to update SQL for this, so I updated to SP1. Afterwards I had to manually start the service again, but it stayed started this time. This allowed every machine except 1 to connect for 1 day. The next day I couldn't connect again and starting the service wasn't solving it. (On a side note, I just checked the services on this machine which is currently connected to ACT and once again SQL Server Agent(ACT7) is not started; SQL Server(ACT7) is started).

I found a post about starting SecurityCmdLnApp.exe as Admin. Did this and it worked to get everyone connected. I can now connect all machines to the database, but one of them has to run SecurityCmdLnApp every morning in order to connect. I don't know if this is coincidence, but I never had any issues with the hanging searches until after running SecurityCmdLnApp.

 

Specs:

Sage ACT! Pro 2011 Version 13.1.111.0, Hot Fix 6

*Database was converted from ACT V5 to ACT V6 then to ACT V13; No errors reported during the conversions

Windows 7 Pro x64 (1 workstation running Win7 Pro 32-bit; DB hosted on 64-bit machine)

SQL Server 2008 Express Edition 10.51.2500.0

Other Programs: Running Quickbooks across same network with no problems; Checked while ACT was lagging and no performance issues with Quickbooks

 

Any help regarding the hanging lookups is appreciated. If anyone has any insight into the connection problems that would be appreciated too. Thank you.

 

EDIT *SOLUTION* 6/5/14 - In case anyone else comes across this problem, I seem to have solved it; I didn't think to try this earlier because I was able to connect to the database, I was just having issues occurring during use. A couple days ago I got a message while trying to add a note that said "The SQL instance is unavailable" and I wasn't able to add any notes. I looked in the KB for this message and it came up with people not being able to log in to their database and getting this message. I had already done most of the solutions, except using the host IP address in the pad file. So I set a static IP address on my host machine and copied the pad file to each workstation, replacing the host name with the static IP address I had set. Since doing this I haven't had a single problem logging in to the db and have had no lag or hang ups at all.

New Member
Posts: 2
Country: USA

Re: ACT 2011 hanging during search/lookup

[ Edited ]

UPDATE

After reading that SQL Server isn't needed except on the machine hosting the DB, I disabled all SQL services on all other workstations. I thought this had helped since my lookups weren't freezing for a while after doing this, but it started again a couple hours later. The freezing is happening pretty much from the moment I login instead of after an hour or so of use. Luckily the freezes are mostly of the 15-30 second variety and not the 2 minute hangups I get once in a while.

I've also found that if I don't log in to ACT for about 10 mins or so after starting up our computers, then it usually logs straight in wihtout telling me the DB couldn't be connected (but I still have the problem with freezing searches). If I get the error that the DB couldn't be connected, I have to run the SecurityCmdLnApp as admin in order to connect.

I've tried detaching the db from SQL on the host machine and opening from the .adf file and it hasn't helped.

If anyone has any insight into this problem your help is greatly appreciated. It's getting very difficult to work with this program when I can't enter notes half the time and it takes forever to do any type of lookups. Thanks.

 

EDIT *SOLVED* 6/5/14 - SEE SOLUTION IN ORIGINAL POST