Community
Showing results for 
Search instead for 
Do you mean 
Reply

Resolution to SecurityCmdLnApp gives Reset Error: System.IO.IOException: Not enough quota is available to process this command.

Bronze Super Contributor
Posts: 1,679
Country: Australia

Resolution to SecurityCmdLnApp gives Reset Error: System.IO.IOException: Not enough quota is available to process this command.

I get an error when I run the SecurityCmdLnApp tool, how I resolved this below:

 

The error when I run SecurityCmdLnApp.exe "ActbySage1!" (as per KB 26994)is:

Reset Error: System.IO.IOException: Not enough quota is available to process this command. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, I nt32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions o ptions, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options) at System.IO.StreamWriter.CreateFile(String path, Boolean append) at System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encodin g, Int32 bufferSize) at System.IO.StreamWriter..ctor(String path, Boolean append) at SecurityCmdLnApp.?.?(String[] ?)

 

So to fix this I googled the error, there are MS KB articles that talk about increasing your Virtual Memory size or turning off UAC. Neither of these worked for me.

 

Whilst logged in as the user (who has local admin rights), we'll call him "Dave".

What I did was create a new user on the machine with local machine administrator rights, called "Evolution".

Logged in as "Dave" Start | run | type "cmd" and right click the entry that appears, click run as Administrator.

This gives us a CMD box with admin rights.

Then in this CMD box, type runas /u:evolution "c:\windows\system32\cmd.exe"

It will ask you for the password you gave the evolution user, enter it and you'll have a second CMD box open up.

In this second CMD box, type

cd \Program Files (x86)\ACT\Act for Windows\ <enter>

SecurityCmdLnApp "ActbySage1!"

and bingo it works.

 

Now running ACT! as the user works, opens database etc.

The other error I had whilst doing this was a windows security error (Error 5, 15105), setting explicit file permissions on the .ADF, .ALF files fixed this.

 

This was using Sage ACT! Pro 2012, SQL Server 2008 R2 Express.