Community
Showing results for 
Search instead for 
Do you mean 
Reply

Remote database won't sync, error says different version

New Member
Posts: 1
Country: USA

Remote database won't sync, error says different version

I have a remote database from ACT version 2011Pro (13.0.401.0 HF2) on a Windows XP laptop that works fine but won't sync. As soon as synchronization is started I get an error saying "Synchronization has failed. The remote database is using a different ACT! version than the main database. Contact your administrator for assistance." I am the administrator Smiley Sad .

 

I have built two new remote databases for new users and both have the same problem. I also have another remote user, whose remote database was built earlier (before me) and it works fine. When I study the difference I see that the Schema version on the Main database and the working remote database are the same. The schema version on my new databases, just built from the main database, are different (lower numbers). However if I run a schema update through ACTDiags on the new remote databases it completes successfully but does not change the schema revision. Apparently ACTDiags logs into SQL (this is 2008 R2) as the sa user so security should not be a problem.

 

Any help would be greatly appreciated. I have spent way too much time on setting up these remote databases.

 

Thanks,

Craig

Bronze Contributor
Posts: 1,394
Country: USA

Re: Remote database won't sync, error says different version

Hello Craig.

 

First, I am not an engineer.

 

I've found over the years that it is extremely important that the host and remote dbs need to be the same. 

 

I'm not sure what happens behind the scene when a backup runs, but that just makes sense to me. 

 

I would first delete the remote and recreate it from the host after making sure that both installations of ACT are the same version.  Then see if that works.

 

Other than that, I'm sure one of the more learned gurus on the board will jump in with more technical help.

John Purdy
ACT! Premium 2016 (V. 18)
Dell XPS Ultrabook with 4GB, Win 10 Pro, & Office 365, 32bit