Community
Showing results for 
Search instead for 
Do you mean 
Reply

Remote DB Scheduler - not showing current DB file

Copper Contributor
Posts: 120
Country: USA

Remote DB Scheduler - not showing current DB file

I setup a remote DB. I actually crated 3 separate DBs form the original host during the process. I have since disabled the 1st on the host.

 

I am on the remote trying to schedule auot-sync/auot-back-up and when i go to the scheduler to create a task, it only shows me the 1st DB I created which has not been accessed or updated for a week.  How do i get it to show me the current DB? It is in that same directory along with the other 2 DB i created butonly the 1st is showing.

 

Additionally, is it ok to delete the old ones onthe remote or is there a specific proces for removing them as they are no longer needed.

Nickel Contributor
Posts: 249
Country: United_Kingdom

Re: Remote DB Scheduler - not showing current DB file

You should just be able to browse to the pad file for the new database, double check that you are looking at the correct folder.

 

The old databases if not required can be deleted via ACT! menu Tools -> Database maintenance -> Delete Database  or you can use ACTDIAG to detach the database then browse to the folder where the database files reside and then just delete them.

Copper Contributor
Posts: 120
Country: USA

Re: Remote DB Scheduler - not showing current DB file

That's what I did but it is only showing me 1 of 3 .pad files. the other 2 are there in Windos Explorer but not in Act when I try to schedule a task.

 

The Delete is greyed out in the host machine so I can't delete. Why is that?

Nickel Contributor
Posts: 249
Country: United_Kingdom

Re: Remote DB Scheduler - not showing current DB file

Are you 100% sure you are browsing to the correct place where the PAD files are as even if you create a new txt file and then change the file extension to .pad scheduler will see that file in the list of files when looking for the "file name and Location", Obviously it wouldn't open it but it is just looking for the file extension.

 

On the machine I would make sure that "Hide extensions for known file types" is unchecked so you can double check.

 

The reason why the delete database is missing is because the user is not an ACT! Administrator. Try logging on to the remote as a user that has administration rights if you can't logon to ACT! then use ACTDIAG to detach the database and then you have to manually delete the files.

Copper Contributor
Posts: 120
Country: USA

Re: Remote DB Scheduler - not showing current DB file

I am 100% sure I a in the correct folder. It is only showing me 1 of 3 PAD files that are there. I tried putting another file in there and it does not show either. I tried with both the remote user and the Admin user logged in and neither works. This is on user computer, not the host.

 

Regarding deleting the DB I was logged in as Admin on the host machine and it was greyed out.

 

I just noticed it is allowing me to delete 1 DB.  It is showing that this 1 remote DB is hosted on the Admin computer when in fact it is on a user machine.  The other 2 DB say they are bieng hosted on the user machine which is correct and they are both greyed out and cannot be deleted on the host.  That doesn't make sense since they are all hosted on the same user mmachine and have all been successuflly synced that way. None have been opened on the host machine.

 

Copper Contributor
Posts: 120
Country: USA

Re: Remote DB Scheduler - not showing current DB file

Any update on this?

 

I still cannot delete a remote DB as the function is greyed out. I am logged in as Admin on the host machine with all priveleges.

 

On the Remote machine i have logged in as Admin and as Standard user and in both instances when I try to create a task in Act Scheduler it only shows 1 .PAD file and I have 3 or 4 now in the same folder.  I created a new Remote DB and it still does not show up.

Nickel Super Contributor
Posts: 939
Country: USA

Re: Remote DB Scheduler - not showing current DB file

Detach the database from SQL using ACTDIAG.  Use the bottom half of this KB article for instructions - http://kb.swiftpage.com/app/answers/detail/a_id/14139/kw/14139

Then, delete the files from Windows Explorer.

 

Regarding scheduler...only thing I can think of is:

1. The confusing two ACT folders that get created for local and shared documents folder.

2. Turn off UAC.

3. Confirm that the .pad file exist and that the scheduler is looking for a .pad file.

Michael Matthews
Bridge Concepts, Inc.
Fort Worth, TX
www.bridgeconcepts.com