Community
Showing results for 
Search instead for 
Do you mean 
Reply

Putting System Fields in Report Headers - Date and Time report printed

Accepted Solution Solved
Copper Contributor
Posts: 34
Country: United States
Accepted Solution

Putting System Fields in Report Headers - Date and Time report printed

Trying to insert date and time fields into report header so I know which report version I'm looking at.  Using the normal process inserting fields into report but I can't seem to get it to go in.  Acts like it puts it in but doesn't show on report template nor when I run the report. I am the administrator so what am I doing wrong?  Searched the forum and the user base and can't seem to find topice any where but maybe my search string isn't right.  Thanks for any help.

Accepted Solutions
Solution
Accepted by topic author jtbamford
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 34
Country: United States

Re: Putting System Fields in Report Headers - Date and Time report printed

Solved. Unlike placing other fields when you place system fields you don't just click them in,  you have to create rectangle by clicking and dragging mouse to create shape starting on the left of the position you want.Different than placing regular fields which automatically create the shape. #2 below.

 

  1. Enable the System Field tool in the Toolbox.
  2. Place your cursor near the left edge of the position that you wish to place the field, click your left mouse button, and then drag to the right to create the new field.
  3. When you release the left mouse button, the Select System Field dialog box appears.

 

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Putting System Fields in Report Headers - Date and Time report printed

I would suggest that you check one of the standard report templates to see how it's handled there. Typically the run date and time is put into the page header or footer.
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Contributor
Posts: 34
Country: United States

Re: Putting System Fields in Report Headers - Date and Time report printed

I just did that aand re-tried on my report.  Found one that had it in the footer so I tried it in my report on the footer. I tried placing the Print Date field in the footer.  What happens when I do that is I get this weird field thing (2 actually...one for field and one for label) showing up on the template that is virtually a line with 3 square dots in it that are the corners of the field. I move it around a little and get it to open up to look normal ...there is one for label and one for field. When I right click on it for Properties it only has Font and Style but nor Format properties like the fields I saw in the standard report I looked at.  Meaning (to me) that both fields there are only text fields not the system field I was trying to put on there.  Do you recognize these symptoms?  Have I got something set wrong somewhere?  I looked at both the Label and System field and both were only text. Thanks.
Solution
Accepted by topic author jtbamford
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 34
Country: United States

Re: Putting System Fields in Report Headers - Date and Time report printed

Solved. Unlike placing other fields when you place system fields you don't just click them in,  you have to create rectangle by clicking and dragging mouse to create shape starting on the left of the position you want.Different than placing regular fields which automatically create the shape. #2 below.

 

  1. Enable the System Field tool in the Toolbox.
  2. Place your cursor near the left edge of the position that you wish to place the field, click your left mouse button, and then drag to the right to create the new field.
  3. When you release the left mouse button, the Select System Field dialog box appears.