Community
Showing results for 
Search instead for 
Do you mean 
Reply

Problem accessing my primary database.

New Member
Posts: 3
Country: Canada

Problem accessing my primary database.

After a couple of months of not using ACT I tried accessing my main DB yesterday. I got an error message saying that my DB is compressed but does not reside in a read only database or filegroup. This file must be decompressed. Could not open new database IAW.DB. Create database aborted. Unfortunately the flash drives I used for back up got lost. Anyone have any ideas about how I can reclaim my DB? 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Problem accessing my primary database.

Hello Balfour,
Welcome to the ACT! Online Community. ACT! and SQL do not work well with compressed files. You will need to browse to the directory where you database is stored (the folder that contains the .ADF, the .ALF, .PAD and [database files] folder for your database) and decompress the files:

- Right-click on the folder where your ACT! database resides and select Properties

- Click the Advanced button under the General tab

- Clear the checkbox for "Compress contents to save disk space" , click OK, then click OK again

 

The time it takes to decompress the files depends on the size of the files within the directory. When the decompression is done, then try opening your database again.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 3
Country: Canada

Re: Problem accessing my primary database.

Hi Greig, thanks for your help. Problem solved. I actually did try your solution earlier but obviously didn`t 'decompress' all the files and it didn`t work but I`m happy to say everything is now OK. Thanks, Ian Wilson