Community
Showing results for 
Search instead for 
Do you mean 
Reply

Password required upon opening ACT

New Member
Posts: 15
Country: Canada

Password required upon opening ACT

After using ACT for many months, I am suddendly prompted to provide a password.  I have a user name in the box, but I do not know my password.  I never had to use a password before, I am stuck.  I can not work and do not know what I would have used as a password.
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Password required upon opening ACT

It sounds as if your database may be in 'Recovery' status within SQL.  To check this:

- click on the Windows Start button >

if XP operating system > click on Run > enter the command 'actdiag' and hit enter

if Vista or Windows 7 > enter the command 'actdiag' into the Search field

- when Actdiag opens, you may get some error messages > click on Continue to open the program

- once it is fully open > you will see the word Databases in the left hand column > click on it and select Database List

- Find your database name in the list and look at the Status column > does it say 'Recovery'? 

 If it says 'Online', this is not the problem.

- If it has a status of 'Recovery', you can follow these steps:

1. left click in the Gray box next to the name of your database to highlight the whole line

2. scroll to the right to find the location of the database files

3. browse to the folder that contains your database files

4. copy/paste them to a different folder (making a backup copy)

5. in the original folder > rename the files associated with your database (ADF, ALF, and Database Files folder) - add the word 'old' to the beginning of each file.  You can delete the PAD file, it will be recreated later.

*At this point, you have made a backup copy of your database and renamed the files associated with the database.

6. in Actdiag > left click in the gray box beside your database to highlight the line

7. right click on your database name > select Delete Database from the menu.

8. now that your database name has been removed from the Actdiag list > you can rename the original files back by removing the word 'old' from them.

9. open Act > it will give a message that the last opened database cannot be found (this is expected because the PAD file was deleted)

10. click on Open Database > change the file type to 'ADF' (at the bottom of the Browse screen) and browse to the folder that contains your database files

11. select the ADF file and Act! will now open and verify the database.

 

 

Greg Martin
Sage
New Member
Posts: 15
Country: Canada

Re: Password required upon opening ACT

Hi Greg

 

Thanks for the information.  I was able to get to the page you are reffering to but it said that my file is SUSPECT.  Under the database options, there is no data.  When I try to copy the files it said that the files are in use.  Any suggestions?  I did not make a formal back up from the list, I just copied them as I was told by an Act advisor to save the files on my zip drive. Unfortunately, I have since deleted them.

 

Thank you

 

Vicki

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Password required upon opening ACT

Hey Vicki,

Suspect is the same as Recovery, just different versions of Act. 

 

I'm surprised that the files are in use... but, they can be released by stopping the 'SQL Server (Act7)' service.  To do this:

- close Actdiag

- click on the Windows Start button

for XP > select Run > enter the command 'Services.msc'

for Vista/Win7 > enter 'Services.msc' into the Search area

- hit enter and the Windows Services screen will launch

- on the Services screen > scroll down to 'SQL Server (Act7)'

- click on it to highlight and then select 'Stop'

- with this service stopped, you can now copy the database files and then rename them.

 

Once the copy and rename are completed, you'll then use the Services screen to 'Start' the 'SQL Server (Act7)' service.

 

With the service restarted, you can now continue with the previously listed steps (delete db through Actdiag/rename db files back to original/open db using ADF file). 

 

Greg Martin
Sage
New Member
Posts: 15
Country: Canada

Re: Password required upon opening ACT

This is what happened when I tried to open the file.  It said it was converting it then gave me the message below, am I doomed........

 

Thanks

 

Vicki

 

The log scan number254:967:18 passed to log scan in database ‘March 2009’ is not valid this error may indicate data corruption or that the log file (.ldf) does not match the data file (.mdf) if this error occurred during replication , re-create the publication. Otherwise restore it from back upif the problem results in a failure during start up.  could not open the new database ‘March 2009’  CREATE DATABASE IS ABORTED

 

P.S I do not have any other back up.........

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Password required upon opening ACT

Unfortunately this is an indication of corruption within the database.  At this point there are 3 options:

1. Restore from backup (not viable because you don't have a backup)

2. Contact the Act! Support team to see if they can resolve the error.

3. Contact the Act! Database Services group to see if they can resolve the error.

 

To contact Act! Support, call 800-927-3989.  You will be routed to Customer Service for support options before getting to the support group.

 

To contact the Database Services group, visit the following link and follow the instructions.  There is a charge for using Database Services that is based upon the number of contacts in your database, a fee scale chart is located on the information form. 

http://www.act.com/support/databaseservices/index.cfm

 

Knowledgebase article for error received: http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=1449...

 

 

Greg Martin
Sage
New Member
Posts: 15
Country: Canada

Re: Password required upon opening ACT

Thanks for all your help, my tech guy suspects a worm or trogan horse.  I will have it looked at first to see if they can resolve the problem, if not I will use the conatcts you suggested.

 

Thanks and have a great day

 

Vicki