Showing results for 
Search instead for 
Do you mean 

Opening data base fails after Windows Update

New Member
Posts: 4
Country: USA

Opening data base fails after Windows Update

I am so frustrated.  I've tried everything I know how to do.  I love ACT when it functions properly but I shouldn't have to have a master's degree in computer science to open my data base.

AND, we shouldn't have to pay $75 per issue to get our expensive software to work correctly.


Not that the community members are responsible for that ridiculous policy, but I knew you'd let me vent. Smiley Happy


It seems we have narrowed the problem down to this:  everytime my computer does a Windows update, my ACT won't open correctly.  I keep having to do a daily System Restore on my Dell machine to set it back to before the update of approximately 5/25/2012.  If I go back and update far enough, I can get ACT to open.  This was happening on my remote machine (a desktop) and after enough restores, ACT is working ok.


I had to turn off Windows updates to keep ACT working, which just doesn't make any sense.


Now I am having identical problems with my laptop (also a Dell, so it also has a System Restore feature).  In our office the laptop is the "main" database because that's the only way the tech people at Sage could get syncing to work when I paid them $75 for help over TWO DAYS of tech work last summer. 


Anyway, I haven't been able to open the laptop's data base for over a week.  The problems appears to have started after a system update.  I have restored back as far as I can go with no solution to the problem.


I have been poking around the forums here and trying several things but nothing seems to help.

It has been suggested to me that maybe ACT 2010 isn't compatible with the newest Windows updates.  Seems crazy, but it also makes sense.  There is definitely a link between the Windows updates and the errors opening ACT.


BTW the desktop is running Windows 7 and the Laptop is running Vista.  As I said, the desktop is working ok for now; the laptop totally locks up every time I try to open ACT.


We depend heavily on ACT and have for 2 years.  But once in a while we have these crazy tech issues that we can't solve on our own.  I'd appreciate any help anyone out there can give.  I don't want to spend $75 and two business days on the phone with the tech people if I can help it.


I'm hoping there is a simple fix that I'm not clever enough to find.  If not, should I update to ACT 2012?  Or isn't there a hotfix or patch or something out there?  I know I'm not the only one pulling my hair out. Smiley Happy


Platinum Elite Contributor
Posts: 6,867
Country: USA

Re: Opening data base fails after Windows Update

What error are you getting when you try to open the ACT! database? Have you checked to see if the ACT7 SQL server is running?


For what it's worth, on my systems the Windows updates cause no problems with the ACT! databases.

Roy Laudenslager
Retired ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
New Member
Posts: 4
Country: USA

Re: Opening data base fails after Windows Update

I appreciate your quick reply.



I don't know what ACT7 SQL server is.


I printed about 5 different posts and tried the steps but none worked.  One suggested I "detach" the data base from SQL using the ActDiag utility (I feel like I am speaking Russian here). 


It didn't work because I believe it said it couldn't find the SQL server?


To answer your original question, 9 times out of 10 when I try to open ACT on the laptop it just locks the whole machine up.  I get a white screen with the ACT header and a perpetual round "thinking" cursor until I have to hard-power-down my machine.  Nothing else works on the entire machine while this is going on.

Once in a while, instead, I get lucky and get an error message.  Of course I can't generate that message at will but I believe it says my Database could not be accessed...check my network connection and verify server database is available.  Also, it may be necessary to disable the firewall.


Help.  I'm going to scream!!  Smiley Wink

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Opening data base fails after Windows Update

Here is an article with instructions for checking the 'SQL Server (ACT7)' service: KB Article 28216

Start the service and then attempt to open the database.

Greg Martin