Community
Showing results for 
Search instead for 
Do you mean 
Reply

Object reference: Not set to an instance of an object

Accepted Solution Solved
Tuned Listener
Posts: 7
Country: United States
Accepted Solution

Object reference: Not set to an instance of an object

Hello,

 

I am on a windows vista 64 bit machine running Act 2009, version 11.  Everthing was working fine until I completed some design layout working, hiding taps, in the database.  Now when I closeout from the design layout I recieve the "object reference not set......" message.  Reading previous posts I have done the rebuild on the preference file and have used actdiag to delete the prefernce file but the message still comes up.  I can restart ACT and go to design layout, contacts, and make changes.  When I save the changes, I am sent back to the main screen and the Object reference message appears.  If I attempt to go back to design layout, contacts, I am sent to a windows file screen which lists the layout files .cly.  When I attempt to open the file nothing happens. If I go to design layout, contacts, a window opens telling me "the current layout has been modified, would I like to save changes."  No matter if I click yes or no I am sent back to file screen that shows the listing of layout files .cly.  If I completely close out of ACT and start up again, I can get to design layout, contact, but once I exit out the same scenario repeats.  I welcome your suggestions.


Accepted Solutions
Solution
Accepted by dlunceford (Moderator)
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Object reference: Not set to an instance of an object

[ Edited ]

Please see if the information in the following Knowledgebase article provides a possible resolution to this issue:

 

Error: "Error saving layout: Object reference not set to an instance of an object."

Message Edited by ghollister on 12-18-2008 05:49 PM

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

View solution in original post


All Replies
Solution
Accepted by dlunceford (Moderator)
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Object reference: Not set to an instance of an object

[ Edited ]

Please see if the information in the following Knowledgebase article provides a possible resolution to this issue:

 

Error: "Error saving layout: Object reference not set to an instance of an object."

Message Edited by ghollister on 12-18-2008 05:49 PM

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Tuned Listener
Posts: 7
Country: United States

Re: Object reference: Not set to an instance of an object

Bingo.  That did it Greig.  Thank you very much for your assistance. 
New Member
Posts: 2
Country: United States

Re: Object reference: Not set to an instance of an object

The link provided (Error: "Error saving layout: Object reference not set to an instance of an object." ) takes you to a password-protected area. 

 

I have been getting this same error and I need to figure out how to fix it.

 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Object reference: Not set to an instance of an object

That particular article has been merged into another KB article since I made that post. Click below for the new article:

 

Error: "Object Reference not set to an Instance of an Object"

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 1
Country: New Zealand

Re: Object reference: Not set to an instance of an object

[ Edited ]

Doesnt cover creating remote Databases in ACT! by Sage 2007 (9.0) Version 9.0.1.162, Hotfix 1.

 

Tryed following all of the examples provide... nothing works... systems spends 20-30 minutes going through the motions of creating remote database then get this warning come up...

 

Message says...

 

Failed to create remote database "name". Object reference not set to an instance of an object......

 

 

 

 

Message Edited by Allan Proudfoot on 06-13-2009 05:52 AM
New Member
Posts: 2
Country: United States

Re: Object reference: Not set to an instance of an object

[ Edited ]

Not to revive an old thread, but I found this on a search.  Having the same issue.

 

It says error saving the layout and the very cryptic "Not set to an instance of an object", whatever that means.

 

Then in the Companies right hand layout pane, it just says "Error loading layout".  It says this on both the workstation AND the server.  The server uses 96DPI.

 

The user wants 120DPI because it is an LCD monitor with a very high resolution.  Without 120DPI text is very tiny.  Yes you can jack the resolution up, but it's a widescreen monitor and it will look very distorted and blurry.  This person also uses Photoshop, so a crisp native LCD resolution is required for their job.

 

Changing the DPI is NOT AN ACCEPTABLE SOLUTION.  The CORRECT solution would be to release a patch that fixes this bug.  I have it in ACT 2008, but I read people are having it in 2009 also.  This is why we did not renew support.  Why in the world should I pay good money to a company that will not fix a simple problem?

 

We are going to try this... but if you want to verify if it works let me know.

Change the DPI to 96.  Reboot.

Modify the layout to our liking and save it.

Close the database, and reopen it.  Verify it works.

Close Act

Change the DPI back to 120.  Reboot.

See if the database works.  If not, restore it from backup again.

 

If this is not remedied, I will never support Sage software again.  That is a PROMISE. I will also spread bad press regarding Sage to the various social media outlets and blogs.

 

It just surprises me how much this software costs, but there's no quality to back it up.  If I could, we would want it refunded.  We have 8 licenses of ACT.  We switched to ACT from Goldmine thinking it may be better...  We might just go back to Goldmine.

Message Edited by sauerk on 02-03-2010 05:52 AM
New Member
Posts: 2
Country: United States

Re: Object reference: Not set to an instance of an object

It did work changing the dpi to 96, making the changes and saving, then changing the dpi back to 120.

 

Change the DPI to 96.  Reboot.

Modify the layout to our liking and save it.

Close the database, and reopen it.  Verify it works.

Close Act

Change the DPI back to 120.  Reboot.

See if the database works.  If not, restore the layout from backup.

 

 

I reccomend keeping a backup copy of the layout file.

 

What a messy workaround.  At least it got it working.

 

New Member
Posts: 1
Country: United States

Re: Object reference: Not set to an instance of an object

Greg,

I use act 2007 and when I do a check and repair on my database it get the error "object reference not set to an intance of an object" what is more I can creat an new database with nothing but my record in it and I still get the same error if I do a check and repair.

I have run the actdiag program and nothing seems to work please help.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Object reference: Not set to an instance of an object

Hello Jrzsys,

Welcome to the ACT! Online Community. What operating system are you using?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.