Community
Showing results for 
Search instead for 
Do you mean 
Reply

Nothing shows up in a report all of the sudden?

Accepted Solution Solved
Copper Contributor
Posts: 59
Country: United States
Accepted Solution

Nothing shows up in a report all of the sudden?

My version is: ACT! by Sage 2007 (9.0) Version 9.0.1.162

 

I have designed quite a few reports in ACT, and all have worked fine, but now and then, you are editing a report, you save it, and then you run it, and nothing shows up in the body of the report, the header and footer with fields shows up, but nothing, no fields, field label text, pictures, rectangles, etc, nothing shows up??? But then you go back to editing the report template and there it all is, why does this happen? What am I missing?

 

I have a feeling that this is something very simple that I am overlooking, please let me know if you know what is causing this.

 

Thanks for any help I can get!

 

 


Accepted Solutions
Solution
Accepted by topic author TonyGTO
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 59
Country: United States

Re: Nothing shows up in a report all of the sudden?

If anyone out there has this problem, it is the "HideOnEmptySubreports", take a look at the setting, if it is set to "Yes", and there is nothing to show in the sub reports for a certain contact, the detail section will not show up when run, and will not print when run.

 

To make sure you can print a contact report that has nothing in the sub reports (like no notes), set "HideOnEmptySubreports" to "No".

View solution in original post


All Replies
Solution
Accepted by topic author TonyGTO
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 59
Country: United States

Re: Nothing shows up in a report all of the sudden?

If anyone out there has this problem, it is the "HideOnEmptySubreports", take a look at the setting, if it is set to "Yes", and there is nothing to show in the sub reports for a certain contact, the detail section will not show up when run, and will not print when run.

 

To make sure you can print a contact report that has nothing in the sub reports (like no notes), set "HideOnEmptySubreports" to "No".

New Member
Posts: 17
Country: USA

Re: Nothing shows up in a report all of the sudden?

hi there,

how do i find that?

i looked in Edit Template all over and can't find anywhere with parameters.

 

i am on ACT! 2008 w/ SP3

 

the reports used to work for all users but now it's not showing history on some of the users.

I found a few accounts with the user as the Record Manager within this week.

i don't understand why the report is no longer showing.

 

also, can you connect to the ACT! data via ODBC? if so what data source do i use?

Platinum Elite Contributor
Posts: 6,651
Country: USA

Re: Nothing shows up in a report all of the sudden?

In the report editor View | Properties Window
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 17
Country: USA

Re: Nothing shows up in a report all of the sudden?

Hi Roy,

yes, i figured out you meant Properties ... same as Prefences.

 

i've set HideOnEmpty to No and still not a thing.

Platinum Elite Contributor
Posts: 6,651
Country: USA

Re: Nothing shows up in a report all of the sudden?

Properties are not the same as preferences. Preferences are typically applied to a program as a whole. In the ACT! report editor you are writing a program and every object in the template has properties attached to it.
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 1
Country: United States

Re: Nothing shows up in a report all of the sudden?

Hi,  I am brand new to reports.  I made a customized contact report.  The template prints perfect.  When I run the report using my contact only, I receive this error

 

PCL XL error

 

Subsystem:  TEXT

 

Error: Internal Error 0x50

 

Operator: BeginChar

 

Position: 54

 

I tried the suggestion in this discussion and put subgroups to "no"

 

Any suggestions?