Community
Showing results for 
Search instead for 
Do you mean 
Reply

No Option for Datastore Location under Database Fixes

New Member
Posts: 3
Country: United States

No Option for Datastore Location under Database Fixes

I'm trying to get ACT 2006 to work over a VPN connection. I get the "cannot find database supplemental files" error. I keep seeing instructions to go into act8diag, Database Fixes then to Datastore Location. Mine doesn't have Datastore Location. The bottom of that menu is Preferences.

Moderator
Posts: 4,395
Country: USA

Re: No Option for Datastore Location under Database Fixes

The option to change datastore location is only available in ACT! 2007 and above.  Follow the Error When Opening a Shared Database section in the KB article below.

 

Error Message "Cannot find database supplemental files folder <Database Name> in this location <Comp... 

New Member
Posts: 3
Country: United States

Re: No Option for Datastore Location under Database Fixes

I've followed that KB article twice. The only thing I can't do is the part under "How to change the datastore location for a shared database", which you said is only available in 2007. I wish the KB articles were more clear about that. Even after manually changing the server name to the IP in the PAD file, if I go to Help > About > Database Information, it still shows the location of the supplemental files as the server name, not the IP. Any other suggestions? I can open files via VPN, so I know the connection is working. The database has been successfully shared over a LAN for over a year, so I know that's working.
New Member
Posts: 1
Country: United States

Re: No Option for Datastore Location under Database Fixes

There is a way to make that change.  As I recall, it is holding a key or something while opening the Database Information off of About ACT.  I had a database and had to do this long ago.  Now, adding a new database, I have to do the same thing and cannot remember the 'trick'.
New Member
Posts: 3
Country: United States

Re: No Option for Datastore Location under Database Fixes

Actually, I found a workaround by editing the .hosts file.