Community
Showing results for 
Search instead for 
Do you mean 
Reply

Making the dialog box for adding Products Work!!

Accepted Solution Solved
Copper Contributor
Posts: 6
Country: South_Africa
Accepted Solution

Making the dialog box for adding Products Work!!

Hi,

I am using (Sage ACT! Pro 2012 Version 14.1.108.0 English (United States)) as a trial and i can not enter the monetary value of my opportunities as i am unable to enter,create or Add a new product either directly in the product add box or via the define fields menu.

 

Is this a trial version restriction ?

 

I keep getting the following errors:

In the dialog box there is a red icon and when i point on it : [ Value is not a decimal number]

and when i click OK

[one or more errors have been detected.Place your mouse on the red indicator to display the error message.]

 

How can this be overcome if it is not a trial restriction?????

 

PLEASE assist.

 

Many thanks

 

Chris


Accepted Solutions
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 6
Country: South_Africa

Re: Making the dialog box for adding Products Work!!

PROBLEM SOLVED!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

 

1) In South african versions of Windows 7, the program uses the comma as a decimal character and in America you use the Decimal point or vice versa. To rectify the settings for Amercan programs do the following:

2) Control Panel>Regional and Language> Enlish United States MUST be chosen (Not English South Africa)

3) click on Additional settings and where it asks for the DECIMAL SYMBOL> select / highlight the symbol in the box and type a decimal point in the box> click apply> exit and reboot your PC.

 

Thank you for the effort given

 

PS: Quickbooks have the same issues in South Africa.

 

Best Regards

 

Chris

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Making the dialog box for adding Products Work!!

Hello Chris,
Welcome to the Sage ACT! User Community. You should have the full functionality with Opportunities in the trial version. Check these things:
- Make sure the status of the Opportunity is "Open"
- Make sure you have products in the product list
- Are adding Products under the Products tab in the Opportunity

As for the error, this is usually an indicator the you have not entered in valid data in a required field.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 6
Country: South_Africa

Re: Making the dialog box for adding Products Work!!

Hi Greig,

 

I have checked everything you have noted, even checked the settings on the modifications area for products.

 

I can not find anything wrong, This is really ticking my watch the wrong way.

What do i do now,

They say insanity is when someone tries to do the same thing over and over, but expect a differant result every time!

This is how i feel, i really want to use this software but right now everyday i sit a play with the settings that do not alter the outcome means i get further and further behind on my contact management.

 

Can i download a differant trial version and install it over this one, BUT i need to keep all the info in the database, I do not want to loose all the hours i have put in so far.

 

It is only the fact that when I click on "Add" on the Product tab in the opportunity section that i can do the following:

Add / edit the list item and put in a new product, no issues.

As soon as i choose it from the drop down list it brings the correct price into the Selection box.

Immediately the first red icon comes up at the Total box.

As soon as i choose the quantity all the remainding boxes get red icons.

Then i select type of product,

I click "OK" and then get the error message telling me to point my mouse over the red icon and see what is wrong,

When i click "OK" i am then returned to the enrty box with the red icons next to all the boxes.

All i can do now is click "Cancel" and the box goes away.

 

All i can do is leave all my opportunities with a zero figure as i can not load any sales figures.

 

Please get me some help on this issue!

 

For the rest the program works wonders, only i have no idea what my pipeline value is, just how many opportunities i have.

 

Sorry for being a pain in ass, I just want to get this thing sorted.

 

Thank you & Best regards

 

Chris

 

Copper Contributor
Posts: 6
Country: South_Africa

Re: Making the dialog box for adding Products Work!!

Just a thought :

My software installed on the C drive but i have my database on my D Drive. Could this affect anything? everything else works like a charm except the product add function on the opportunity side.

 

Thanks

chris

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Making the dialog box for adding Products Work!!

The location of the database should not affect this type of function.

 

Are you using the ACT! Demo database, or did you create a new database?

 

- If you are using a new database, have you made any customizations to the Opportunity fields?

Try opening the ACT! Demo database and testing the Opportunity functions within it.  Does it exhibit the same problem?

Note: Username for demo is 'Chris Huffman', no password.

 

- If you are testing in the Demo, create a new database (File > New Database) and test the functions within it.

Greg Martin
Sage
Copper Contributor
Posts: 6
Country: South_Africa

Re: Making the dialog box for adding Products Work!!

Hi Martin,

 

I tested the Demo database with no customizations to it     : Same result

created a new database with no customizations to it           : Same result

 

I just select the product, nothing else yet, then it starts to flag red icons for me.

 

I hope this is not to much of a toffee, I really need this to work

 

Thanks

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Making the dialog box for adding Products Work!!

I've been unable to reproduce this issue.  What regional version of Windows is installed?  When creating the new database, do you recall which currency was selected?  

This may be a conflict with regional settings, to further test:
Create a new contact field through the Tools > Define Fields option.  Create a new field of type 'Currency'.  Clicking on Finish/Close you will be prompted to add it to the layout... add it to the layout.  With this field added to the contact layout, are there any issues with this field?  Does it display the red icon/flag?

Here is an article with more in-depth instructions about creating fields: KB Article 15335

Greg Martin
Sage
Copper Contributor
Posts: 6
Country: South_Africa

Re: Making the dialog box for adding Products Work!!

Hi Greg,

 

Windows 7 Professional 64 Bit

Currency = Rands ( I did think of this as well and tested by creating a new database using $ but exact same issue in a new database in a new folder even after reinstalling the software from scratch.

 

Tried your advise on creating a new field:

Made them Characters and only the total Value i made a decimal.

The decimal part is flagged red even before i start typing.

 

Obviously this trial has something wrong,

1) Please tell me where i can get a new copy that works

2) All this time i am losing on my trial, Where do i get that back now as well?

 

Sorry Greg, my tether is now starting to unravel at a tremendous speed,

 

I have deadlines to meet and this is not helping.

 

Please give me software system that works.

 

Chris

 

Sage 1.JPG

 

 

 

SAGE2.JPG

 

 

Hope the pics help

 

Thanks

 

 

 

 

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Making the dialog box for adding Products Work!!

Chris,

See your Private Notes for a different download link.

 

If the uninstall/reinstall with the new file does not work, I would think it related to regional settings.

Greg Martin
Sage
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 6
Country: South_Africa

Re: Making the dialog box for adding Products Work!!

PROBLEM SOLVED!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

 

1) In South african versions of Windows 7, the program uses the comma as a decimal character and in America you use the Decimal point or vice versa. To rectify the settings for Amercan programs do the following:

2) Control Panel>Regional and Language> Enlish United States MUST be chosen (Not English South Africa)

3) click on Additional settings and where it asks for the DECIMAL SYMBOL> select / highlight the symbol in the box and type a decimal point in the box> click apply> exit and reboot your PC.

 

Thank you for the effort given

 

PS: Quickbooks have the same issues in South Africa.

 

Best Regards

 

Chris