Community
Showing results for 
Search instead for 
Do you mean 
Reply

Login failed for user 'ACTADMIN'

New Member
Posts: 3
Country: USA

Login failed for user 'ACTADMIN'

Trying to create a new database on recently installed Act! Pro Version 21.0.295.0, Update 5, running on a local machine (no network) using Windows 10

 

I keep getting the following error message:

 

Cannot open database FSI' requested by the login.  The login failed.

Login failed for user 'ACTADMIN'.

 

I've tried uninstalling and reinstalling several times before and after I talked to ACT tech support who was unable to help.

 

Any ideas on how I can create a new database?

Highlighted
Silver Contributor
Posts: 1,715
Country: United_Kingdom

Re: Login failed for user 'ACTADMIN'

This is only pertinent if you also chose actadmin when trying to create the new database.

 

Just a nag at the back of my mind regarding ACTADMIN where you try to create a new database with a user called actadmin.

 

I believe ACTADAMIN is a system user name that is used as part of the ACT database creation process and if you also select this as the desired user name when prompted when creating a new database creates odd errors during the build process as it thinks there are duplicate user names.

 

If the above is not the case -

 

Is the FSI the name of the database that you are trying to create? If not will check to see if this is part of the internal build processes.

 

Are you able to open the demo database or any other database you may have on the machine?

 

Have you tried running ACT with admin rights? (Right click on the ACT icon and select run as administrator.)

New Member
Posts: 3
Country: USA

Re: Login failed for user 'ACTADMIN'

I must have clicked something wrong.

 

I have tried several names in trying to create a database...FS, FSI, FSIS, and others.

 

I have never set up an administrator or a user called ACTADMIN.

 

I followed your suggestion in trying to run as administrator to set up a new database and failed.

Nickel Super Contributor
Posts: 401
Country: United_Kingdom

Re: Login failed for user 'ACTADMIN'

You could try turning on DEP, this KB article http://kb.act.com/app/answers/detail/a_id/20124 or use this to turn off the password policy http://kb.act.com/app/answers/detail/a_id/23446 Please scheck the event viewer and see if there any info about "login failed for user 'ACTADMIN'

The ACTADMIN user is an SQL user that is created in SQL when you install Act! along with a few others. 

New Member
Posts: 3
Country: USA

Re: Login failed for user 'ACTADMIN'

Thank you for your response but still no success!

Nickel Super Contributor
Posts: 401
Country: United_Kingdom

Re: Login failed for user 'ACTADMIN'

You could un-install act! if not using SQL for anything else uninstall everything to do with that. Disable UAC on the machine re-boot and try installing it again by running the application by right mouse clicking the setup.exe and select run as Administrator. Hopefully this will install SQL and act! OK.

 

 

There is also a KB article on how to manually install SQL instance http://kb.act.com/app/answers/detail/a_id/38183 if you have want to manually install it prior to installing act!. 

 

 

Or you could install management studio express MgmtStudio 64BIT\SQLManagementStudio_x64_ENU.exe from here https://www.microsoft.com/en-gb/download/details.aspx?id=42299 and check that the act! SQL users have been created OK.