Community
Showing results for 
Search instead for 
Do you mean 
Reply

LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

New Member
Posts: 4
Country: USA

LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

[ Edited ]

 

If anyone has an idea, I'd appreciate it. We've tried all the steps I can find for trouble-shooting this issue

Using ACT! 2011 Premium with on Host computer database for Remote Synchronization.

  • One remote user using ACT! 2011 Premium
  • Both using Windows 7 Ultimate OS
  • Windows Firewall is selected to allow access to Sage Act public and private on both computersBoth publisher & subscriber versions of ACT! versions are the same
  • Unpacked and installed Remote database. All OK and normal


LogMeIn VPN

  • Have setup a Logmein Hamachi VPN.
  • All LogMeIn connections are tested and pinged.
  • LogMeIn window shows correct PC name on both ends

 

 

Publisher Host

  • Publisher Host is using Network Synch Server
  • Publisher database is working fine.
  • Synch set is set to Host computer name
  • Connection is the standard Port 65100


Remote DB location after installation

  • Can login with remote users User/Pass
  • Tried click Synch Database
  • NOTE: connection seems to be established. The remote DB location shows Windows hourglass for about 130 seconds then we get this Error Message


Message:
ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

No matter what we have tried, we get this same Error each time in Synch Log
The synch Log on the host publisher database is Empty.

Since this is Premium, we cannot click Accept incoming Synch" on the host Publisher database
Network Synch server is running as a service on Host Publisher
It is configured for the correct database and Port 65100


Things tried at Remote DB location after installation so far:

Created a new RDB again carefull checking the Sync Set as per LogMeIn instructions on Sage Support

ON Synch Panel of Remote PC "Manage Connections", have tried using both Logmein IP addresses rather than hostname computer name. Still fails

Ping
- Tried to ping the IP address for the Host from the Remote subscriber pc. But it fails
- Tried to ping the IP address for the Remote subscriber from the Remote subscriber pc. Ping is successful
- Tried to ping the IP address for the Host from the Hostpc. Ping is successful.
NOTE:  Apparently this is correct behaviour for LogMeIN  VPN

 

Firewall

have tried turning OFFF Windows firewall on both PC's at same time. Still no connection. Same Error

New Member
Posts: 4
Country: USA

Re: LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

new information

 

I am certain now that LogMeIn VPN is connected properly between the 2 Windows 7 computers

We can browse for files on the other computers and copy paste or move files easily between computers

NOTE:  the Sage Act support article instructs to enter the LogMeIn virtual IP number of the VPN computer in "manage connection" on the remote PC computer before Synching Database.  That is instead of setting it up with the ComputerName.

When that is done on the Remote PC, when synch is tried, this Error Message appears

[ Info | 9/15/2011 11:07:05 AM ]Message: Sync remote client created.
[ Error | 9/15/2011 11:07:28 AM ]Message: Unable to acquire Sync Server object. Server Error Description: Failed to find main database [\\WIN7-SG48P2E\ActDatabase_Main] for sync.

It is looking for the computer name and since Sync Set connection is on the LogMeIn IP address it fails.

When we use the correct Computer Name, the Error is the same as above post

Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

This message seems to indicate that the connection is made with the Host Publisher database. And I'm back to the issue of Check to be sure "accept incoming sync" i and that "Network Sync Service is running"

THIS is not possible with Act 2011 Premium. It is one or the other. So the message is even incorrect.


There must be a simple solution to this, but I'm spinning in circles now having tested all other possibilites to find they are all correct

What's left?

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

New Member
Posts: 4
Country: USA

Re: LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

Thanks, Mike

Hope this does it.

Cheers,

Jan

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

And make sure both databases (publisher and subscriber) are open. 

Greg Martin
Sage
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

Greg, shouldn't need that with Network Sync Server - or are you saying for a test?
New Member
Posts: 4
Country: USA

Re: LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

[ Edited ]

Thanks again, Mike

 

The updates and hotfixes solved the problem

 

Summary for any others using LogMeIn VPN

 

The VPN is free and easy to install.  Recommend you selectl Mesh style network
The free version has slower speed and bandwidth. With signfigant data transfer will have to pay for Pro version.

 

I had to keep creating or recreating new remote databases while we solved this. This brought about an unforseen Human Error situation

 

After the hotfixes got things setup, we were still failing and getting the Network connection Error

Unable to acquire Sync Server object. Server Error Description: Failed to find main database [\\HOSTPC\DB_Main] for sync.

After several hours mucking about, I realized I had to ADD the new database name t to the Network Sync server on the Host machine... the error message above is too general to tell you that. But once Added then Synch was going fine

BIG Thanks to MIke Lazarus. 

 

Cheers

 

PS did not need to have the databases open. That would be application synch I believe

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

Ah - mixed messages...  posted in 'Sage ACT' board, but it's actually a Premium issue. 

 

You are correct, don't need the publisher open with Network Sync.

Greg Martin
Sage
Astute Commentator
Posts: 19
Country: USA

Re: LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

I have a similar issue to a certain extent, but I am using PuTTY (localhost) to connect and sync.  I have been using this work around for 7 years for the Network Sync with XP machines with no issues, but now both the publisher (host) and remote are on Windows7 Premium machines it does not work.

 

Sync Settings:

Database Name:  ABC

Database Machine: <machineHome>

Main Database:  123

Sync Set:  <name>

Sync Server Machine: <name of the machine>

Sync Server Port:  65100

 

When i use the remote machine's actual name I get the error message "ACT! is unable to connect to the sync server..make sure "accept incoming sync" is turned on" and when I use "localhost" as the remote machines actual name i get the error "unable to acquire sync server object".  

 

I have tested my Putty connection and I know i am connected the host machine.  Both databases are "up to date".  Any suggestions?

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: LogMeIn VPN with Act 2011 Remote DB synchronization. "ACT! is unable to connect to the sync server..."

When you installed ACT! on the new publisher machine did you specify the Accept Incomming Syncs option  Also with Windows 7 you may need to disable or make an exception in the User Access Control (UAC).

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129