Community
Showing results for 
Search instead for 
Do you mean 
Reply

Linking Company to Contact puts wrong country code into the phone numbers on the contact

Copper Elite Contributor
Posts: 227
Country: New_Zealand

Linking Company to Contact puts wrong country code into the phone numbers on the contact

This will probably not be a problem for USA users, but whenever I have a contact linked to a company, and update the contact with the company details, it always changes the country code in the phone numbers  to (01), that is the USA code. It is so changed that even deleting or backspacing over the number and re-keying it does not fix it. As soon as you exit that field the (01) pops up again. The only way to correct the phone number is to bring up the 'edit phone number' window, change the country (which actually shows up there as what it should be i.e. New Zealand) to some other random country, ok out, edit number again, change back to New Zealand, ok out again.... what a hassle. My local support is able to replicate the problem but can only offer the above work around (which I figured out for myself).
 
The phone number always appears correctly in the Company record. If I create a Company from a Contact, it does not happen.
 
Using Act 9.0.1.162, Win XP. As far as I can ascertain all my country settings are right everywhere else on my computer and in Act, the default country being New Zealand. Is there another default country code buried somewhere deep in the company database that I have not found??
 
Have any Canadians or Poms or Aussies run into this?
 
 
Copper Elite Contributor
Posts: 227
Country: New_Zealand

Re: Linking Company to Contact puts wrong country code into the phone numbers on the contact

Has anyone else run into this bizarre problem??
New Member
Posts: 7
Country: UK

Re: Linking Company to Contact puts wrong country code into the phone numbers on the contact

Hi Graham,
 
If you click on the square grey box right next to the phone number - it will give you the option to change the format of the telephone number, it should be quite easy to swap this over.
 
Thanks
Copper Elite Contributor
Posts: 227
Country: New_Zealand

Re: Linking Company to Contact puts wrong country code into the phone numbers on the contact

Hi,
Just changing or correcting the format doesn't work, it still leaves the (01) country code in place. The only thing that works so far is using the format button to change to some (any) other country, ok out, then change back to New Zealand. Whenever I update the contact with company data it changes the country code to (01). The companies and My Record all have NZ as the country.
By the way, when i click on the format button, the country field in the format window actually has New Zealand in it. It's just when you look at the phone number in the contact record you see the (01) prefix. I'm more than ever convinced it's a bug. 
New Member
Posts: 3
Country: Australia

Re: Linking Company to Contact puts wrong country code into the phone numbers on the contact

Hey GrahamS,
 
I'm just doing some work with phone fields myself in ACT! 9.0 & there's a couple of things you might like to check out in regards to your issue.
 
If you go to "Define Fields" via the Tools Menu and find the "Phone" field for both Contacts & Companies...there is a "Customise field behavior" step in the wizard that describes a "Link to Contact/Company field". You might want to check how this field affects your data (between Company & Contact).
 
Also, as I think you mentioned all your clients are in NZ, try setting the "Country" fields for both Contact & Company to default to NZ. This is the 3rd or 4th step in the wizard. Again - find these under the "Define Fields" area.
 
Hope this gets you somewhere.
 
BTW. If you know how to drop the "[COUNTRY]" code prefix from the front of displayed phone/fax/mob fields I'd appreciate some HELP! I can see a check box in the "General Preferences" but this only seems to auto display the country code ahead of any field input. With this checkbox "off" you still get the Country Code as soon as you enter a phone number in the field. Other than masking the first part of the field via the Design Layout - I'm stumped!
 
Peter (Sydney)
 
Copper Elite Contributor
Posts: 227
Country: New_Zealand

Re: Linking Company to Contact puts wrong country code into the phone numbers on the contact

Hi Peter,
 
Thanks for your input. I have got the Company and Contact main Phone fields linked (I have created a new separate DDI Phone field in the contact record). I have found it most efficient when creating new contacts to create their new Company record first. I have all the main address fields etc linked so when I create the contact those fields get filled in when I choose their company (by this stage the company is in the company drop list on the contact record.)  The only problem has been the US country code issue I have been discussing. I have found that 'Create new Company from Contact' does not fill in as many fields on the Company record even though thay are linked. I think it is because I have put in a lot of custom fields (e.g. street address as well as postal address) so it will fill them in if linked from company to contact but not from contact to company.
 
None of my New Zealand contacts display the country code in the phone field, and I have formats for all the number layouts e.g. 0800 or 0900 (#### ### ####); 027 or 021 (mobiles - ### ### ####) and the main one being the area code and number e.g. 09 443 5800 - ## ### ####. It seems the default format attaches to the country, not the Phone or fax field within the records (see Edit Formats button in the Edit Phone Formats window). So my default for NZ is the area code and number above, and when I put in a toll free or mobile number I have to manually select the format.
 
Also found that some countries have a default format of 'Free form' and won't allow you to add any other formats.
 
Finally I have found with the (1) prefix issue that if I click on the Edit Phone Number button, and left click on the country field twice (which is already showing NZ) then ok out the (1) goes away! Much quicker than the rigmarole I described in my first msg. Play with that one!.
 
Hope I haven't bored you to tears, and hope this helps.
 
Graham (Auckland)
New Member
Posts: 3
Country: Australia

Re: Linking Company to Contact puts wrong country code into the phone numbers on the contact

Hey Graham,
 
Don't you hate having to find "work arounds"?! Biggest problem is that the solution is typically tacit & either you forget it yourself or the person with the answer leaves the organisation!
 
Thanks for your help with the Country Code - perhaps it is because you've created your own "Phone" field that you're no longer seeing "[64]" in front as I do with the System Fields. As soon as I type anything in a Phone field - up pops "[61]".
 
I've masked the first part of the field by editing the Design Layout & I'll let the users loose with this.
 
Cheers,
 
Peter.
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Linking Company to Contact puts wrong country code into the phone numbers on the contact

[ Edited ]
Canadians wouldn't see this, they're also CC=1
 
But yes, it was a known issue with ACT! 9.0 (fixed in 10.0) that creating contacts from Companies, from Outlook, from Web (and maybe other areas) would set the CC as 1... but not even in every view. It was an odd thing.
 
You can select the number - ctrl-X
Save the record
Paste the number back in - ctrl-v
Sometimes this works if you have the Country field set in the address
 
There is no other solution other than an upgrade to fix this one


Message Edited by GLComputing on 03-07-2008 05:08 AM