Community
Showing results for 
Search instead for 
Do you mean 
Reply

Layout & Customize Toolbox Is Empty

Bronze Contributor
Posts: 1,394
Country: USA

Layout & Customize Toolbox Is Empty

Two weeks ago I was having a problem calls not rolling over.  The solution took me down a path that cleared my preferences and then ultimately had to re-create each of the items that were not rolling forward.

 

I mentioned that because it may be related; I just don't know how.

 

I've loaded the add-on program "Middle Pane" which I use all day long.  However, I am no longer able to get ACT to recognize the "Middle Pane" in the customize toolbox.  The DLL is in the Tools subdirectory and I've rebooted several times (not just for this but because I use a Windows based system too).

 

ACT Directory.png

 

As you can see the DLL is there, but the customize toolbox comes up empty. 

 

Has something broken between the two?

John Purdy
ACT! Premium 2016 (V. 18)
Dell XPS Ultrabook with 4GB, Win 10 Pro, & Office 365, 32bit
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Layout & Customize Toolbox Is Empty

John,
I did some testing and found it works with 2012, but not 2013. This is probably due to .NET 4.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Bronze Contributor
Posts: 1,394
Country: USA

Re: Layout & Customize Toolbox Is Empty

[ Edited ]

Greig, do you have a recommendation as to what I should do?

 

It was working with 2013 until I fixed the activities rollover problem. 

John Purdy
ACT! Premium 2016 (V. 18)
Dell XPS Ultrabook with 4GB, Win 10 Pro, & Office 365, 32bit
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Layout & Customize Toolbox Is Empty

[ Edited ]

Did you purchase the add-on from one of our development partners?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Bronze Contributor
Posts: 1,394
Country: USA

Re: Layout & Customize Toolbox Is Empty

Hi Greig.  I downloaded it from the developer's forum:

 

http://community.act.com/t5/Sage-ACT-Developer-Downloads/Middle-Pane/m-p/315/highlight/true#M9

 

 

John Purdy
ACT! Premium 2016 (V. 18)
Dell XPS Ultrabook with 4GB, Win 10 Pro, & Office 365, 32bit
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Layout & Customize Toolbox Is Empty

[ Edited ]

It sounds like the .dll is failing to load when ACT! opens. Since this tool is just a prototype add-in (meant to give developers a tool they can expand on), I have no knowledge of how to fix it. I would make a post in the thread you downloaded the tool from and see if anyone there can offer you a solution.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Bronze Contributor
Posts: 1,394
Country: USA

Re: Layout & Customize Toolbox Is Empty

The sugggestion on the original Middle Pane post didin't help.  I did find this in the Knowledgebase, but am unsure where the file mentioned is located:

 

"You have created a custom control but it is not available when working in Design Layouts.

Before custom controls will appear in the custom control portion of the toolbox, Component must have Act.Shared.CustomControlAttribute(true) attribute set to True."
 
The file I think I'm looking for is "Component".  I suspect that it is an editable file to which I can validate that "True" is set.
 
 
John Purdy
ACT! Premium 2016 (V. 18)
Dell XPS Ultrabook with 4GB, Win 10 Pro, & Office 365, 32bit