Community
Showing results for 
Search instead for 
Do you mean 
Reply

LIBRARY NOT REGISTERED

New Member
Posts: 4
Country: United States

LIBRARY NOT REGISTERED

I use Act 2009 / Version 11.1 with Windows XP.  I also use Office XP Standard.   My problem is that whenever I try to merge a document using a template, Word opens up but has not merged the template with the contact.  It is completely blank.  If I try to edit the templates I get the following error message:  Library not registered.  (Exception from HRESULT: 0x800 280 1D (TYPE_E_LIBNOTREGISTERED)).    I have repaired Word and I have done a integrity check and reindexed in Act.

 I previously had a problem with Word 2007 continually trying to make me register. 

 

Any help would be appreciated.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: LIBRARY NOT REGISTERED

Hello fremer,

This issue can be due to having a previous installation of Office 2007 on your machine. Please see KB Article 21040 for a possible solution.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 4
Country: United States

Re: LIBRARY NOT REGISTERED

My original post of Oct. 17th is printed below.  I followed all of the suggestions in your KB Article 21040.  Everthing worked except for the area where I was supposed to navigate to C\windows\assembly.   None of the items related to microsoft.office.interopt.word or microsoft 2007 items. 

I have figured out that if I have Word already open when I merge with a template that it will work and merge.  I still have the same original error message if I try to edit a template.  ( I uninstalled Act and xp office and reinstalled them al per the article above)

Do you have any other suggestions?

Thanks,

 

(I use Act 2009 / Version 11.1 with Windows XP.  I also use Office XP Standard.   My problem is that whenever I try to merge a document using a template, Word opens up but has not merged the template with the contact.  It is completely blank.  If I try to edit the templates I get the following error message:  Library not registered.  (Exception from HRESULT: 0x800 280 1D (TYPE_E_LIBNOTREGISTERED)).    I have repaired Word and I have done a integrity check and reindexed in Act.

 I previously had a problem with Word 2007 continually trying to make me register. 

 

Any help would be appreciated.)

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: LIBRARY NOT REGISTERED

Try the process in KB 23311 to register the redemption.dll file

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 4
Country: United States

Re: LIBRARY NOT REGISTERED

Dear Greig, 

 

 I followed the instructions in KB 23311 to register the redemption.dll file.   It was registered succesfully without doing anything special.  I still have the same problems.   I have to have one copy of Word open in order to have a template merge correctly.   I also still receive the same error message about my library not being registered.

 

Do you have any other  suggestions?

 

Thanks,

Bill Fremer

 

 

New Member
Posts: 4
Country: United States

Re: LIBRARY NOT REGISTERED

I Still need help with this problem.   Does anyone have any additional suggestions to fix this problem?  

 

Thanks,

 

Wm. Fremer