Community
Showing results for 
Search instead for 
Do you mean 
Reply

Import CSV - only some of the rows are imported

Skilled Commentator
Posts: 71
Country: United Kingdom

Import CSV - only some of the rows are imported

Hi;

I've imported over 20 separate CSV files so far - and had a few niggles with special characters, empty rows, empty columns etc - but nothing that couldnt be solved in a few minutes - and some the CSV's had > 1000 rows

 

I now have an  800 row CSV causing the following issues:

 

 

The progress bar 'stops' say eg 1/3rd of the way though - and I'm back into ACT! contacts with only a eg 1/3rd of the contacts imported

 

I have done the following in all combinations:

1) Exit act before each import

2) Run Database maintenance

3) Removed special characters from the spreadsheet

4) Run the 'clean' function in excel against all cells to remove hard breaks etc etc

5) Ensured no empty rows or columns

 6) reordered my excel CSV file  - think that there might be a 'break' associated with certain rows

 

 

The number of lines that gets imported is also variable - 318 one time, 321 the other

 

I delete all partial imports from Act - exist act! and perform DB maintenance before each import try.

 

I’ve also saved the CSV as CSV (windows) and CSV DOS formats – again no difference.

 

Also - DeDupe is not turned on  

 

Might eb a red herring – but my first import attempt actually loaded something like 700 of the 800 rows, but since then I’ve only managed the 300 or so type rows.

Some of the cells have formats that would be incorrect for their fields

 

Eg  a phone number field may contain text and some of the cells have ‘hundreds’ of characters when the field will only take 50 (I assume act just drops the excess characters which would be fine for me ) – but maybe my assumptions are wrong and this is causing the issues.

 

 

 

 

 

 

 

 

Skilled Commentator
Posts: 71
Country: United Kingdom

Re: Import CSV - only some of the rows are imported

OK - looks like it's solved-  but potentially a bug here.

 

It was failing on a few of the First Name cells having a what appears to be more than 60 or so characters in them.

 

No special characters like line breaks or hard breaks or non printing characters - just a lot of characters.

 

 

 

Is ehre such a thing as an 'Import Report'.

 

I cant believe there is no diagnostic information available during or after the import

Bronze Super Contributor
Posts: 1,170
Country: USA

Re: Import CSV - only some of the rows are imported

True - the Act! built-in import capability is SERIOUSLY lacking - not sure why they think of it as a 'lesser' citizen, but there you go