Community
Showing results for 
Search instead for 
Do you mean 
Reply

I cant "share" my databse

Copper Contributor
Posts: 30
Country: United States

I cant "share" my databse

 

Act 2009 (V.11)

Host is on WIndows 7 64 bit

 

I have 3 licenses, yet know I cant share my database for some reason.  I cannot keep the check mark by "Share databade".  I have tried:

 

1) deleting the PAD file.  I delte it ten use the ADF? or whatever file to open it so another pad file will be created but it tells me that it cannnot be opened due to the database being in use.  Not sure what would be using it at thhat time though.

 

2) deleting extra shares.  I went to Computer maagement to verify if I had multiple shares, I only had one.  Well I tried to delete that share anyway and it wouldnt let me.  Does nnot even give the option to delete it. 

 

Not sure what else to do.  Basically I am getting the error "cannot find supplemental file folders, ....."

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: I cant "share" my databse

Test to see if this is database specific, or possibly location specific.

 

Create a new database (File > New Database) in a different location - suggest creating new folder on C: drive (ex: ACT DB) for the new database > enable sharing > test accessing this new database.

 

If successful and you do not have remotes sychronizing to production database, create a backup of the production database, then restore it using the 'Restore As' option to give it a new name.  Share the newly restored copy and test accessing. 

 

If successful, 2 options:

1. Start using newly restored copy of database as production.

2. Move the production database to the new location.  Here is an article with instructions for moving a database: KB Article 23392

Greg Martin
Sage
Platinum Elite Contributor
Posts: 6,653
Country: USA

Re: I cant "share" my databse

Start ACT! on the server by right clicking on the icon and selecting Run as Administrator. You should then be able to share the database.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Contributor
Posts: 30
Country: United States

Re: I cant "share" my databse

[ Edited ]

No sir Roy, that didnt work.  Just tried it. ALthough I did try right clicking this time as you requested, but I also have under properties the box checked to always run this as administrator.  Any other ideas please?

 

* Just saw Greg reply so I am trying that out now.  Will advise...

Copper Contributor
Posts: 30
Country: United States

Re: I cant "share" my databse

Greg, even after creating TWO new databses, neither one would allow the "share database" to stay ticked.  I am debtating on uninstalling and reinstalling but I have heard that may cause even more problems. 

 

I am ust not sure what happened.  This thing worked fine a few months back. 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: I cant "share" my databse

How long is the 'Share Database' option staying enabled? Is it resetting after a reboot?

Uninstalling/Re-installing Sage ACT! is pretty quick and easy - its the SQL portion that could be a potential problem. I would reinstall ACT! (not SQL) and test, before looking at reinstalling SQL.

If you can pinpoint a timeframe for when the 'share' is disabled, you may find additional errors within the Windows Event Viewer.
Greg Martin
Sage
Copper Contributor
Posts: 30
Country: United States

Re: I cant "share" my databse

It wont enable at all. The check mark never goes by it. I try to enable it, the box pops up telling me "when you share your database, files associated with it are accessible to users o network". I click ok, and ten go back to Tools>Database Maint ad the check mark is not there.

I am about to the point of uninstalling and reinstalling (Or move to a different database provider). I dot know what else to do.
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: I cant "share" my databse

[ Edited ]

Hello broddam,
First, note that although we have had no significant issues, ACT! 2009 is not officially supported on Windows 7.

 

Have you tried disabling User Account Control? This KB article provides instructions:
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2566...

You can also try running under the built-in Windows administrator account. See this KB article:
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2179...

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 30
Country: United States

Re: I cant "share" my databse

Yea Greg I am aware of that, but like you said, no significant issues reported. Also I have had this database shared before. I will try the two KB articles you mention.
Copper Contributor
Posts: 30
Country: United States

Re: I cant "share" my databse

Greg, neither of those KB articles seemed to help. Am I down to uninstalling and reinstalling? Also if I do that, should I uninstall and reinstall on all three systems or just the server?