Community
Showing results for 
Search instead for 
Do you mean 
Reply

History Reports

Copper Contributor
Posts: 13
Country: Australia

History Reports

Hi,

 

Our database of clients is seperated into a monthly and area call cycle, I have created a report which allows me on Monday of every week to print out a listing of the clients each sales rep needs to call on each week, and it also provides them with history from the last 3 months of what they have discussed with the client. I have one huge issue, of the six sales reps we have it works for five of them, for the other one rep the report does not pick up the clients history.

 

I have checked his user details against all other reps, I have checked his private settings, I have checked the filter settings and also have checked how he enters the details into Act. All his details match all other reps details exactly. I'm hoping it's something simple that I have overlooked, any help would be muchly appreciated.

 

Thanks

Mel

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: History Reports

If it works for five and not for the sixth, then it has to be the filter settings when you run the report. Are you selecting all users on the general tab?
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Contributor
Posts: 13
Country: Australia

Re: History Reports

Under the general tab all users are selected, under the histoy tab only the specific sales rep is selected.

 

I created a generic report for all reps, the only thing that changes is the rep. Is it possible there might be something under his user that I may have missed. I have deleted the report and re-created it and the same thing occurs.

 

Mel

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: History Reports

I assume you've tried that User on another machine and one of the other users on his machine?

 

All on a LAN (ie not sync)?

 

You might try this (create a backup first):

Create a new user

Delete the user with the problem and reassign all items to the new user.

Copper Contributor
Posts: 13
Country: Australia

Re: History Reports

Hi Mike,

 

Thanks for the tip. I've tried the user on a different machine and it didn't work, I tried another user on his machine and the other users history came through, I also tried to run the report under a user that has full administration rights and it didn't work. All our reps have remote databases so I tried running his report on a live database and still no luck, I deleted the user and created a new one and ran the report and still nothing. I'm about to start pulling my hair out.

 

Any other ideas?

 

Mel

 

 

Bronze Elite Contributor
Posts: 2,545
Country: New_Zealand

Re: History Reports

Do you ever see any of the problem users History in any report?

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


Copper Contributor
Posts: 13
Country: Australia

Re: History Reports

Hi Graeme,

 

Yes the history for this particular sales rep does show up in the History Classic Report and also in the Notes and History Report.

Bronze Elite Contributor
Posts: 2,545
Country: New_Zealand

Re: History Reports

I suggest that you run a History report on a record that contains a History item from that user. Then logon as that user and add a history item in two different ways to that record;

1. By creating then closing an Activity (for the problem user) against the record. The closed history should appear and..

2. Create a History item from using the Ctrl + H keys to pop the Cretae History box and enter a history.

 

Run the report and see that you an see the new histories in the report. Log off ACT! and logon as a different user and run the report to see if the history report is the same as running it as the problem user. 

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


Copper Contributor
Posts: 13
Country: Australia

Re: History Reports

Hi Graeme,

 

Ok, so I've run the Notes and History Report on the problem user and it pulls the history for his clients. I've created an activity for the probelm user and closed it off and also created a history item under the problem users login. I ran a Notes and History Report under his login and it pulled the two test pieces of data that i entered. I then ran the report I created and no luck with the history. I logged on as a different user and ran the new report for the problem user and still no history. I'm beginning to think I'm going mad.

 

Therefore, I have a problem either with the user or the report. I find it strange that I have created only one new report to which 5 of the other reps shows history on however not on the sixth rep. I also find it strange that I can pull the problem reps history when I run one of the other history reports.

 

I've checked the filters of the report, the private settings, user settings, user permissions, tried running under an administrator, tried running under a non administrator, tried running on both remote and live databases, created a new user and made the old user inactive, got rid of all the criteria with the user, entered history under the new user and run the report and still I'm left with one rep who's user won't pull the history.

 

Mel

Bronze Elite Contributor
Posts: 2,545
Country: New_Zealand

Re: History Reports

So now open one or both of those History items that does not show and allocate it to another user (Record Manager) and run the same test. Are the results different?

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog