Community
Showing results for 
Search instead for 
Do you mean 
Reply

Help! "The database <NAME> could not be accessed." I've tried everything...

New Member
Posts: 11
Country: USA

Help! "The database <NAME> could not be accessed." I've tried everything...

Hello all,

 

I'm getting the following error when trying to open my database: "The database <NAME> could not be accessed. In order to access this database, check your network connection and verify that your database server is available. It  may be necessary to disable any firewall software on your computer or the server."

 

The problem seemed to crop up today on PC2 when I uninstalled AVG anti virus and and installed CA (computer associates) anti virus. The database resides on PC1 and PC1 can access the database just fine. PC1 also installed CA anti virus today but did not uninstall AVG (it wasn't installed to begin with). PC2 gets to the database through a shared folder on PC1 and we've been running this setup for years.

 

Here is what I've tried so far: complete uninstall of CA anti virus, complete uninstall / reinstall of ACT (3x), started / restarted SQL Server (Act 7), disabled firewalls (on PC1, even when I select disable it remains green and enabled... separate issue or related?), and looked through many of the fixes here: http://kb.sagesoftwareonline.com/app/answers/detail/a_id/19640/~/error%3A-%22the-database-%26lt%3Bda...

 

Other information that might be useful:  XP SP3, ACT 2009

 

Also, I was able to do an ACT! update through the main menu, but that didn't help.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Help! "The database <NAME> could not be accessed." I've tried everything...

Hello Adam,
Have you tried creating a new admin account on that machine? It may be an issue with the user profile.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 11
Country: USA

Re: Help! "The database <NAME> could not be accessed." I've tried everything...

Hi Greig, I have not tried that. Could you walk me through this? I don't know how.

 

Also, I saw in another thread to try and rename the PAD file and open with the ADF (?) file, but that didn't work either.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Help! "The database <NAME> could not be accessed." I've tried everything...

If this a shared environment, try having another network user who is able to access the database log into Windows on the problem machine, and see if they can access the database. This should tell you if the issue is with the user profile.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 11
Country: USA

Re: Help! "The database <NAME> could not be accessed." I've tried everything...

I see what you mean. No, it's not a shared environment. I can't use User2's info to log into PC1.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Help! "The database <NAME> could not be accessed." I've tried everything...

Is PC2 able to access and edit all the the shared files on PC1, through Windows (not ACT!)?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 11
Country: USA

Re: Help! "The database <NAME> could not be accessed." I've tried everything...

Yes, I can access the PC1 files from PC2. That said, and I'm not sure if this is related, but if I try to open the ADF file from PC1 it says "ADF files must be on a local device. Files on mapped or shared drives cannot be used." I could copy the database to PC2 local, but won't that create a problem later when I delete the PC2 copy and revert back to the "live" copy on PC1?

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Help! "The database <NAME> could not be accessed." I've tried everything...

That is expected - you can't open an .ADF file across a network, only from the host machine. This sounds like a network access issue. i would double-check to make sure you have added all the appropriate firewall exceptions for the ACT! and SQL files and ports. The list of exceptions is in this KB article:
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2512...

There are individual links at the bottom of this article for CA and AVG.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 11
Country: USA

Re: Help! "The database <NAME> could not be accessed." I've tried everything...

That was it! I needed to disable the CA firewall on PC1. THANK YOU SO MUCH!