Community
Showing results for 
Search instead for 
Do you mean 
Reply

Help needed with shared database problem - on startup only

New Member
Posts: 2
Country: USA

Help needed with shared database problem - on startup only

Can someone please help with a strange problem I'm having?

 

I just installed and registered Act! 12 on a Windows 2008 server (works fine) and a Windows Vista workstation. The database on the workstation will open fine manually (file/open from menu) if Act! is already running. However, when Act! first starts up, it hangs for about a minute and then gives a permissions error about the database, but will then open it fine once I select the local pad file from the dialog box. Database on the server is marked as "shared", and I copied the server's pad file to the workstation's database folder. Workstation user has full control permissions on the DB and supplemental folder.

 

It seems to be having a problem with the database on startup only when it looks for the "last used" database. I even removed that entry from the registry which only helped the one time on startup. Forcing it to open the named DB in settings did not help either.

 

Another thing possibly related, I added all the recommended programs and ports in Vista's firewall, but it still wouldn't run unless I start up Act with the "run as administrator" option.

 

Any advice appreciated.

Thanks,

John

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Help needed with shared database problem - on startup only

Hello JohnK2010,

Welcome to the Act! Online Community!

 

Can you provide us the permissions error you are receiving when starting Act!?

 

For troubleshooting purposes, go ahead and add the program and port exceptions to the firewall/anti-virus software on the server.  Since the server is where Act! is communicating with SQL, the exceptions should be entered on the server.

 

Since you are having to run Act! 'As Admin', that indicates that Windows UAC is enabled.  To set Act! to always 'Run As Administrator', right click on the Act! icon > select Properties > go to Compatibility tab > enable 'Always Run As Administrator' option at the bottom of the tab.

 

If you open a local database (ex: Act!Demo), then close and reopen Act! > does it successfully open the local database?

 

 

Greg Martin
Sage