Community
Showing results for 
Search instead for 
Do you mean 
Reply

Help getting rid off extra prefixes when dialing contact

Tuned Listener
Posts: 44
Country: USA

Help getting rid off extra prefixes when dialing contact

Hi,

I saw in those forums that I'm not the only one with a dial problem.

 

I have tried this in both Act! 2008 and Act! 2009 without success.

including infos from the KB.

 

I have contacts with correct phone number informations but when I try

to call them using the "Contact->Phone Contact..." menu, the contact

info is correct but the phone number to be called is totally wrong.

 

In the control panel: Phone and ModemOptions

- I'm not using a physical modem so I can't "select" it as mentioned in one of the KB articles here.

I'm using a Cisco VOIP line

-  My Location country: Switzerland

- Aera Code 21

- Dialing rules all set to nothing, no prefixes whatsoever

 

Windows XP Regional Settings set to "Location = Switzerland"

 

In Act!, my contact phone is set to 

- Country: Switzerland [41]

- Format: Free Form

- Phone Number: 5609 (this is a local phone number)

 

- Tools -> Preferences -> Communication -> Dialer Preferences...

- My Location->Properties->Edit shows the same info as in the 

Windows control panel

No prefixes, nothing

 

Now I try to call:

- Contacts->Phone Contact...

The "Number to Dial" shows "0 0 1 5609"

 

That means I can never call aynbody directly from Act! without first

editing manually the "Number to Dial" field.

 

If I pick a phone number that is an outside line it still insists

to at least add a 0 in front of it.

 

I have tried everything:

021 123-4567  gives 0 021 123-4567

+41 21 123-4567 gives 0 41 21 123-4567

41 21 123-4567 gives 0 41 21 123-4567

 

Any clue on how to set this to work "as is", as the phone number

is actually entered in the field, and how to actually take in account

the options set in the phone and modem options?

 

I also have tried to change the Free Form option and impose, for

example, a 4 digits phone number only, still, it adds the prefixes.


Act! also sometimes keeps insisting, in the contact phone fields,

to as a country "Suisse [1]" which is nonsense, why is it in French

when everything is in English on my machine, and 1 is not Switzerland

it's the US.

Even if I set it back to "Switzerland [41]" it comes back to "Suisse [1]".

But anyway, that's the least of the problems, since it still adds prefix

numbers when not needed.

 

Thanks for any help. This is driving me crazy.

 

 

Steve JORDI
_________________
Volcanoes at www.sjordi.com/volcanoes
Platinum Elite Contributor
Posts: 6,653
Country: USA

Re: Help getting rid off extra prefixes when dialing contact

ACT! goes through the Windows dialer, all ACT! does is pass the TAPI canonical formatted phone number to Windows and the Windows dialer does the actual dialing. Unless you can successfully dial the number with the Windows dialer, the ACT! dialer won't work.
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Tuned Listener
Posts: 44
Country: USA

Re: Help getting rid off extra prefixes when dialing contact

Hi

Thanks for the reply. 

Where is the actual Windows Dialer so I can try?

I have no such thing on my XP Pro SP3.

I checked the control panel to add windows components, no such thing.

Are you talking about the Phone and Modem Options?

 

Steve JORDI
_________________
Volcanoes at www.sjordi.com/volcanoes
Platinum Elite Contributor
Posts: 6,653
Country: USA

Re: Help getting rid off extra prefixes when dialing contact

Phone and Modem options is part of it, that's where you set up the dialing rules. In fact, they are partially replicated in the ACT! preferences. I haven't had occasion to actually do dialing from Windows in years and I'm not set up for dialing but try Start | Programs | Accessories | Communication | HyperTerminal.
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Tuned Listener
Posts: 44
Country: USA

Re: Help getting rid off extra prefixes when dialing contact

Ah ok hyper terminal...

I didn't think about it, I thought it was only for telnet.

But this doesn't help much.

 

Problem is that I get prefixes even though none of them are shown in the 

modem and phone options.

 

Very strange

Steve JORDI
_________________
Volcanoes at www.sjordi.com/volcanoes
Copper Contributor
Posts: 22
Country: Switzerland

Re: Help getting rid off extra prefixes when dialing contact

Hi could you solve it?

I have the same issue with a German ACT! 11.0. If you click Phone Contact, ACT! always adds a 0. But nowhere in the modem settings is a 0 set.
Martin Viegas
Consultant Customer Service CRM